首页 > 代码库 > POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)

POJ 3468-A Simple Problem with Integers(线段树:成段更新,区间求和)

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 62228 Accepted: 19058
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15
感觉成段更新好难,lazy数组标记用的很巧妙,以后多做题一定要把它理解透了。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define L long long
using namespace std;
const int INF=1<<27;
const int maxn=500010;
L lazy[maxn],sum[maxn];
void push_up(int root)
{
	sum[root]=sum[root*2]+sum[root*2+1];
}
void push_down(int root,int l,int r)
{
	if(lazy[root])
	{
		int m=r-l+1;
		lazy[root*2]+=lazy[root];
		lazy[root*2+1]+=lazy[root];
		sum[root*2]+=(m-m/2)*lazy[root];
		sum[root*2+1]+=(m/2)*lazy[root];
		lazy[root]=0;
	}
}
void update(int root,int l,int r,int ql,int qr,L v)
{
	if(ql>r||qr<l) return ;
	if(ql<=l&&qr>=r)
	{
		lazy[root]+=v;
		sum[root]+=(v*(r-l+1));
		return ;//
	}
	int mid=(l+r)/2;
    push_down(root,l,r);
    update(root*2,l,mid,ql,qr,v);
    update(root*2+1,mid+1,r,ql,qr,v);
    push_up(root);
}
L query_sum(int root,int l,int r,int ql,int qr)
{
	if(ql>r||qr<l) return 0;
	if(ql<=l&&qr>=r) return sum[root];
	push_down(root,l,r);
	int mid=(l+r)/2;
	return query_sum(root*2,l,mid,ql,qr)+query_sum(root*2+1,mid+1,r,ql,qr);
}
int main()
{
    int n,Q,i,ql,qr;L v;char op;
    scanf("%d%d",&n,&Q);
  	//memset(lazy,0,sizeof(lazy));
  	//memset(sum,0,sizeof(sum));
  	for(i=1;i<=n;i++)
	{
		scanf("%lld",&v);
		update(1,1,n,i,i,v);
	}
	while(Q--)
	{
		getchar();
		scanf("%c",&op);
		if(op=='Q')
		{
			scanf("%d%d",&ql,&qr);
			printf("%lld\n",query_sum(1,1,n,ql,qr));
		}
		else
		{
			scanf("%d%d%lld",&ql,&qr,&v);
		    update(1,1,n,ql,qr,v);
		}
	}
  return 0;
}