首页 > 代码库 > POJ 2236Wireless Network

POJ 2236Wireless Network

题目来源:http://poj.org/problem?id=2236



Wireless Network
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 16470 Accepted: 6942

Description

An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B. 

In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations. 

Input

The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats: 
1. "O p" (1 <= p <= N), which means repairing computer p. 
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate. 

The input will not exceed 300000 lines. 

Output

For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.

Sample Input

4 1
0 1
0 2
0 3
0 4
O 1
O 2
O 4
S 1 4
O 3
S 1 4

Sample Output

FAIL
SUCCESS

Source


题解:简单并查集~~


AC代码:

#include<cstdio>
#include<cmath>
const int Max=1002;
struct Node{
 double x,y;int loc;
}father[Max];
int set[Max],pos=0,n,dx,dy;
char ch; double d;
bool dis(int x,int k){
	double di=sqrt(pow(father[x].x-father[k].x,2)+pow(father[x].y-father[k].y,2));
	if(di<=d)	return true;
	return false;
}
int find(int k){
	if(k==father[k].loc) return k;
	int temp=find(father[k].loc);
	father[k].loc=temp;
	return temp;
//	return find(father[k].loc);
}
int main(){
	scanf("%d%lf",&n,&d);
	for(int i=1;i<=n;i++){
		scanf("%lf%lf",&father[i].x,&father[i].y); 
		father[i].loc=i;
	}
	while(getchar(),~scanf("%c",&ch)){
	if(ch=='O'){
	scanf("%d",&dx);
	for(int i=0;i<pos;i++){
		if(dis(dx,set[i])){
			int tempx=find(set[i]);
			father[tempx].loc=find(dx); 
		}
	}
	set[pos++]=dx;
	}
	else {
	scanf("%d%d",&dx,&dy);
	int tempx=find(dx),tempy=find(dy);
	if(tempx==tempy) printf("SUCCESS\n");
	else printf("FAIL\n");
	}
	}
	return 0;
} 



POJ 2236Wireless Network