首页 > 代码库 > HDU - 2594 Simpsons’ Hidden Talents

HDU - 2594 Simpsons’ Hidden Talents


Problem Description
Homer: Marge, I just figured out a way to discover some of the talents we weren’t aware we had.
Marge: Yeah, what is it?
Homer: Take me for example. I want to find out if I have a talent in politics, OK?
Marge: OK.
Homer: So I take some politician’s name, say Clinton, and try to find the length of the longest prefix
in Clinton’s name that is a suffix in my name. That’s how close I am to being a politician like Clinton
Marge: Why on earth choose the longest prefix that is a suffix???
Homer: Well, our talents are deeply hidden within ourselves, Marge.
Marge: So how close are you?
Homer: 0!
Marge: I’m not surprised.
Homer: But you know, you must have some real math talent hidden deep in you.
Marge: How come?
Homer: Riemann and Marjorie gives 3!!!
Marge: Who the heck is Riemann?
Homer: Never mind.
Write a program that, when given strings s1 and s2, finds the longest prefix of s1 that is a suffix of s2.
 

Input
Input consists of two lines. The first line contains s1 and the second line contains s2. You may assume all letters are in lowercase.
 

Output
Output consists of a single line that contains the longest string that is a prefix of s1 and a suffix of s2, followed by the length of that prefix. If the longest such string is the empty string, then the output should be 0.
The lengths of s1 and s2 will be at most 50000.
 

Sample Input
clinton homer riemann marjorie
 

Sample Output
0 rie 3题意:求第一串的前缀和第二串的后缀的最长公共字串思路:将两个串连接起来,用KMP的next[]数组求串的前缀和后缀匹配,最后好要谈论答案串的长度问题
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
using namespace std;
const int maxn = 1000005;

int next[maxn], n, m;
char pattern[maxn];
char s1[maxn], s2[maxn];

void getNext() {
	int len = strlen(pattern);
	next[0] = next[1] = 0;
	for (int i = 1; i < len; i++) {
		int j = next[i];
		while (j && pattern[i] != pattern[j])
			j = next[j];
		next[i+1] = pattern[i] == pattern[j] ? j+1 : 0;
	}

	int ans = next[len];
	if (ans == 0)
		printf("0\n");
	else {
		s1[ans] = '\0';
		if (n > m) {
			if (ans > m)
				printf("%s %d\n", s2, m);
			else printf("%s %d\n", s1, ans);
		}	
		else {
			if (ans > n)
				printf("%s %d\n", s1, n);
			else printf("%s %d\n", s1, ans);
		}
	}
}

int main() {
	while (scanf("%s%s", s1, s2) != EOF) {
		n = strlen(s1), m = strlen(s2);
		memcpy(pattern, s1, sizeof(s1));
		strcat(pattern, s2);
		getNext();
	}	
	return 0;
}


HDU - 2594 Simpsons’ Hidden Talents