首页 > 代码库 > POJ 1328 Radar Installation(贪心)

POJ 1328 Radar Installation(贪心)

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2

Case 2: 1

首先考虑把坐标维度降下来再考虑贪心算法

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
#include<cmath>
typedef long long LL;
using namespace std;
double d,x,y;
struct node{
    double l,r;
}e[1010];
int cmp(node l1,node l2)
{
    return l1.r<l2.r;
}
int main()
{
    int n,flag;
    int cas=1;
    while(~scanf("%d%lf",&n,&d))
    {
        if(n==0&&d==0)   break;
        flag=1;
        for(int i=0;i<n;i++)
        {
            scanf("%lf%lf",&x,&y);
            if(!flag)  continue;
            if(d<y)  flag=0;
            double dis=sqrt(d*d-y*y);
            e[i].l=x-dis;
            e[i].r=x+dis;
        }
        printf("Case %d: ",cas++);
        if(!flag)
        {
            printf("-1\n");
            continue;
        }
        sort(e,e+n,cmp);
        int ans=1;
        double pos=e[0].r;
        for(int i=1;i<n;i++)
        {
            if(e[i].l>pos)
            {
                ans++;
                pos=e[i].r;
            }
            if(e[i].r<pos)
                pos=e[i].r;
        }
        printf("%d\n",ans);
    }
    return 0;
}

POJ 1328 Radar Installation(贪心)