首页 > 代码库 > HDOJ 2026首字母变大写

HDOJ 2026首字母变大写

首字母变大写

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30463    Accepted Submission(s): 17060



Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
i like acm i want to get an accepted
 

Sample Output
I Like Acm I Want To Get An Accepted
 

Author
lcy
 

Source
C语言程序设计练习(四)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2027 2043 2031 2030 2033 
 

Statistic | Submit | Discuss | Note




水题,AC代码:


#include <iostream>
using namespace std;
int main(){
	char a[105];
	while (gets(a)){
		a[0] = a[0] - 32;
		for (int i = 1; i < strlen(a);i++)
		if (a[i - 1] == ' ')
			a[i] -= 32;
		cout << a << endl;
	}
	return 0;
}


HDOJ 2026首字母变大写