首页 > 代码库 > Problem A: 类的初体验
Problem A: 类的初体验
Description
定义一个类Data,只有一个double类型的属性和如下3个方法:
1. void init(double d);——初始化属性值。
2. double getValue()——获得属性值。
3. void showValue()——显示属性值。
Input
一个double类型的数值。
Output
输出输入的值2次,每次占一行。
Sample Input
3.14
Sample Output
3.14
3.14
HINT
Append Code
append.cc,
int
main()
{
Data data;
double
d;
cin>>d;
data.init(d);
cout<<data.getValue()<<endl;
data.showValue();
}
代码
#include <iostream>
#include <iomanip>
using namespace std;
class Data
{
private:
double a;
public:
void init(double d)
{
a=d;
}
double getValue()
{
return a;
}
void showValue()
{
cout<<a<<endl;
}
};
int main()
{
Data data;
double d;
cin>>d;
data.init(d);
cout<<data.getValue()<<endl;
data.showValue();
}
#include <iomanip>
using namespace std;
class Data
{
private:
double a;
public:
void init(double d)
{
a=d;
}
double getValue()
{
return a;
}
void showValue()
{
cout<<a<<endl;
}
};
int main()
{
Data data;
double d;
cin>>d;
data.init(d);
cout<<data.getValue()<<endl;
data.showValue();
}
Problem A: 类的初体验
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。