首页 > 代码库 > poj 3069 Saruman's Army(贪心)

poj 3069 Saruman's Army(贪心)


Saruman‘s Army
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 3446 Accepted: 1752

Description

Saruman the White must lead his army along a straight path from Isengard to Helm’s Deep. To keep track of his forces, Saruman distributes seeing stones, known as palantirs, among the troops. Each palantir has a maximum effective range of R units, and must be carried by some troop in the army (i.e., palantirs are not allowed to “free float” in mid-air). Help Saruman take control of Middle Earth by determining the minimum number of palantirs needed for Saruman to ensure that each of his minions is within R units of some palantir.

Input

The input test file will contain multiple cases. Each test case begins with a single line containing an integer R, the maximum effective range of all palantirs (where 0 ≤ R ≤ 1000), and an integer n, the number of troops in Saruman’s army (where 1 ≤ n ≤ 1000). The next line contains n integers, indicating the positions x1, …, xn of each troop (where 0 ≤ xi ≤ 1000). The end-of-file is marked by a test case with R = n = ?1.

Output

For each test case, print a single integer indicating the minimum number of palantirs needed.

Sample Input

0 3
10 20 20
10 7
70 30 1 7 15 20 50
-1 -1

Sample Output

2
4

Hint

In the first test case, Saruman may place a palantir at positions 10 and 20. Here, note that a single palantir with range 0 can cover both of the troops at position 20.

In the second test case, Saruman can place palantirs at position 7 (covering troops at 1, 7, and 15), position 20 (covering positions 20 and 30), position 50, and position 70. Here, note that palantirs must be distributed among troops and are not allowed to “free float.” Thus, Saruman cannot place a palantir at position 60 to cover the troops at positions 50 and 70.

Source

Stanford Local 2006

简单的一道贪心算法题,感觉英文题读起来还是有压力啊,读半天读不懂题意,读懂题意感觉思路就很简单了;
题意就是给你n个点,在r距离内要有点被标记,要求最小的标记点数,利用贪心算法的思路,从最左边没标记的点开始,找到距离r最近的那个点然后标记这个点,标记了第一个点之后,对标记的点之后r距离的第一个点标记,如此进行下去,直到最后一个点。
下面是ac的代码:
#include <stdio.h>
#include <algorithm>
using namespace std;
int x[1001];
int main()
{
    int r,n;
    while(scanf("%d%d",&r,&n)&&r!=-1&&n!=-1)
    {
    for(int i=0;i<n;i++)
        scanf("%d",&x[i]); 
    sort(x,x+n); //对所给的点进行排序
    int i=0,ans=0;
    while(i<n)
    {
        int s=x[i++];//最左边的第一个点
        while(i<n&&x[i]<=s+r) i++;//一直向右寻找直到找到距离大于r的点
        int p=x[i-1];//新加上标记的点的位置
        while(i<n&&x[i]<=p+r) i++;
        ans++;
    }
    printf("%d\n",ans);
    }
    return 0;
}

poj 3069 Saruman's Army(贪心)