首页 > 代码库 > 1000:A+B 输入输出练习I 分数: 1

1000:A+B 输入输出练习I 分数: 1

1000:A+B 输入输出练习I 分数: 1

时间限制:1 秒
内存限制:32 兆
特殊判题:
提交:232
解决: 86
 
<style></style>

题目描述

你的任务是计算a+b。这是为了acm初学者专门设计的题目。你肯定发现还有其他题目跟这道题的标题类似,这些问题也都是专门为初学者提供的。

输入格式

输入包含一系列的a和b对,通过空格隔开。一对a和b占一行。

输出

对于输入的每对a和b,你需要依次输出a、b的和。

如对于输入中的第二对a和b,在输出中它们的和应该也在第二行。

样例输入

1 5
10 20

样例输出

6
30

链接:http://sdjzu.acmclub.com/index.php?app=problem_title&id=147&problem_id=1000

我的代码:

C语言版:

#include<stdio.h>
int main()

{
  int a,b;
  while(scanf("%d%d",&a,&b)!=EOF)
    printf("%d\n",a+b);

return 0;

}

Java 版:

 

import java.util.*;
public class Main {
	public static void main(String args[]) {
		Scanner cin = new Scanner(System.in);
		int a, b;
		while (cin.hasNext()) {
			a = cin.nextInt(); 
			b = cin.nextInt();
			System.out.println(a + b);
		}
	}
}
 
<style></style><style></style>