首页 > 代码库 > 【线段树五】HDU 1698 Just a Hook
【线段树五】HDU 1698 Just a Hook
Just a HookTime Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 15093 Accepted Submission(s): 7489 Problem Description In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length. Now Pudge wants to do some operations on the hook. Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks. The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows: For each cupreous stick, the value is 1. For each silver stick, the value is 2. For each golden stick, the value is 3. Pudge wants to know the total value of the hook after performing the operations. You may consider the original hook is made up of cupreous sticks. Input The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases. For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations. Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents the golden kind. Output For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example. Sample Input 1 10 2 1 5 2 5 9 3 Sample Output Case 1: The total value of the hook is 24. Source 2008 “Sunline Cup” National Invitational Contest Recommend wangye | We have carefully selected several similar problems for you: 1542 1255 1828 1540 3397 来源: <http://acm.hdu.edu.cn/showproblem.php?pid=1698> |
线段树应用---成段更新(lazy)
初始化:
操作1:
更新1--5 value=http://www.mamicode.com/2
过程:
update(int from,int to,int value,int l,int r,int index)
1 5 2 1 10 1
Down(index,r-l+1);
sticks[0]=0;表示:上次没有更新你,你下面的也就不用更新,我往下找找吧
update(int from,int to,int value,int l,int r,int index)
1 5 2 1 mid=5 2
更新stick[2]=2, sum[2]=(r-l+1)*value=http://www.mamicode.com/(5-1+1)*2=10
(这个【1,5】范围内先不用更新到底,假装更新完了)
return ;
操作2:
更新5--9 value=http://www.mamicode.com/3
过程:
update(int from,int to,int value,int l,int r,int index)
5 9 3 1 10 1
Down(index,r-l+1);
sticks[0]=0;表示:上次没有更新你,你下面的也就不用更新,我往下找找吧
update(int from,int to,int value,int l,int r,int index)
5 9 3 1 mid=5 2
Down(index,r-l+1);
sticks[2]=2!=0 ;表示,奥,上次更新过你了,你往下更新一下吧,我要使你孩子的值
-->sticks[4]=2,sticks[5]=2,更新和 sum[4]=6,sum[5]=4;
-->sticks[2]=0 重新置为0,你已经更新完了 等于没有更新你,更新了的是你孩子节点。
……
所以标记的作用在于不用每次更新到叶子节点,有需要的时候再往下更新。
#include <iostream>
#include<stdio.h>
using namespace std;
#define MAXN 100000
int sticks[MAXN*4];
int sum[MAXN*4];
void Up(int index){
sum[index]=sum[index*2]+sum[index*2+1];
}
void Down(int index,int m){
if(sticks[index]){
sticks[index*2]=sticks[index*2+1]=sticks[index];
sum[index*2]=(m-m/2)*sticks[index];
sum[index*2+1]=m/2*sticks[index];
sticks[index]=0;
}
}
void build(int l,int r,int index){
sticks[index]=0;
sum[index]=1;
if(l==r){
return ;
}
int mid=(r+l)/2;
build(l,mid,index*2);
build(mid+1,r,index*2+1);
Up(index);
}
void update(int from,int to,int value,int l,int r,int index){
if(from<=l&&to>=r){
sticks[index]=value;
sum[index]=(r-l+1)*value;
return ;
}
Down(index,r-l+1);
int mid=(l+r)/2;
if(from<=mid)
update(from ,to,value,l,mid,index*2);
if(to>mid)
update(from,to,value,mid+1,r,index*2+1);
Up(index);
}
int main()
{
int T;
int N,Q;
scanf("%d",&T);
for(int i=1;i<=T;i++){
scanf("%d%d",&N,&Q);
build(1,N,1);
while(Q--){
int X,Y,Z;
scanf("%d%d%d",&X,&Y,&Z);
update(X,Y,Z,1,N,1);
}
printf("Case %d: The total value of the hook is %d.\n",i , sum[1]);
}
return 0;
}
来自为知笔记(Wiz)
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。