首页 > 代码库 > 一种排序

一种排序

一种排序

时间限制:3000 ms  |  内存限制:65535 KB
难度:3
 
描述
现在有很多长方形,每一个长方形都有一个编号,这个编号可以重复;还知道这个长方形的宽和长,编号、长、宽都是整数;现在要求按照一下方式排序(默认排序规则都是从小到大);

1.按照编号从小到大排序

2.对于编号相等的长方形,按照长方形的长排序;

3.如果编号和长都相同,按照长方形的宽排序;

4.如果编号、长、宽都相同,就只保留一个长方形用于排序,删除多余的长方形;最后排好序按照指定格式显示所有的长方形;
 
输入
第一行有一个整数 0<n<10000,表示接下来有n组测试数据;
每一组第一行有一个整数 0<m<1000,表示有m个长方形;
接下来的m行,每一行有三个数 ,第一个数表示长方形的编号,

第二个和第三个数值大的表示长,数值小的表示宽,相等
说明这是一个正方形(数据约定长宽与编号都小于10000);
输出
顺序输出每组数据的所有符合条件的长方形的 编号 长 宽
样例输入
1
8
1 1 1
1 1 1
1 1 2
1 2 1
1 2 2
2 1 1
2 1 2
2 2 1
样例输出
1 1 1
1 2 1
1 2 2
2 1 1
2 2 1
?
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
#include<iostream>
#include<cstring>
#include<cstdio>
#include <memory>
#include<queue>
#include<cmath>
#include<set>
#include<algorithm>
using namespace std;
struct rect
{
    int num;
    int length;
    int width;
};
 
bool cmp(rect r1,rect r2)
{
    return r1.num<r2.num||r1.num==r2.num&&r1.length<r2.length||r1.num==r2.num&&r1.length==r2.length&&r1.width<r2.width;
}
 
 
int main(int argc, char* argv[])
{
    int m;
    cin>>m;
    while(m--)
    {
        int m,i,a,b,c,t;
        rect r[1000];
        cin>>m;
        for(i=0;i<m;i++)
        {
            cin>>a>>b>>c; 
            if(b<c)  {t=b;b=c;c=t;}
            r[i].num=a;
            r[i].length=b;
            r[i].width=c;
        }
        sort(r,r+m,cmp);
        for(i=0;i<m;i++)
        {
            if(r[i].num!=r[i+1].num||r[i].length!=r[i+1].length||r[i].width!=r[i+1].width)
            {
                cout<<r[i].num<<" "<<r[i].length<<" "<<r[i].width<<endl;
            }
        }
    }
    return 0;
}