首页 > 代码库 > zoj zju 2989 Encoding 字符串处理

zoj zju 2989 Encoding 字符串处理

Encoding
Time Limit: 2 Seconds      Memory Limit: 65536 KB
Chip and Dale have devised an encryption method to hide their (written) text messages. They first agree secretly on two numbers that will be used as the number of rows (R) and columns (C) in a matrix. The sender encodes an intermediate format using the following rules:


1.


The text is formed with uppercase letters [A-Z] and <space>.


2.


Each text character will be represented by decimal values as follows:

技术分享



<space> = 0, A = 1, B = 2, C = 3, ..., Y = 25, Z = 26 The sender enters the 5 digit binary representation of the characters?? values in a spiral pattern along the matrix as shown below. The matrix is padded out with zeroes (0) to fill the matrix completely. For example, if the text to encode is: "ACM" and R=4 and C=4, the matrix would be filled in as follows:


A = 00001, C = 00011, M = 01101(one extra 0) The bits in the matrix are then concatenated together in row major order and sent to the receiver. The example above would be encoded as: 0000110100101100


Input


The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.


Each dataset consists of a single line of input containing R (1 <= R <= 21), a space, C (1 <= C <= 21), a space, and a text string consisting of uppercase letters [A-Z] and <space>. The length of the text string is guaranteed to be <=(R*C)/5.


Output


For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and a string of binary digits (R*C) long describing the encoded text. The binary string represents the values used to fill in the matrix in row-major order. You may have to fill out the matrix with zeroes (0) to complete the matrix.


Sample Input


4
4 4 ACM
5 2 HI
2 6 HI
5 5 HI HO


Sample Output


1 0000110100101100
2 0110000010
3 010000001001
4 0100001000011010110000010


题意:输入r,c,str  。把字符串str的每个字符转换为5位二进制数。然后按图片中的表示,把这串二进制数放入r*c的矩阵当中。空格做00000处理。如果没填满r*c的矩阵就把剩下的位子用0填充。然后按行把这个矩阵的信息输出来。

#include<stdio.h>
#include<string>
#include<iostream>
#include<map>
#include<string.h>
using namespace std; 
char mp[30][30];
int bol[1000];
int dir[4][2]={0,1,1,0,0,-1,-1,0};
int main()
{
	int t; 
	string str;
	int cas=1;
	int r,c;
	scanf("%d",&t);
	
	while(t--)
	{
		 scanf("%d%d",&r,&c);
		 getchar();
		 getline(cin,str);
		 memset(mp,0,sizeof mp);
		 int pos=0;
		 for(int i=0;i<str.length();i++)
		 {
			 int bin;
			 if(str[i]==' ')
				 bin=0;
			 else bin=str[i]-'A'+1;
			 int binarr[10];
			 for(int j=4;j>=0;j--)
			 {
				 binarr[j]=bin%2;
				 bin/=2;
			 }
			 for(int j=0;j<5;j++)
			 {
				 bol[pos++]=binarr[j];
			 }
		 }
		 int x=1,y=1,ff=0;
		 int xx,yy;
		 mp[1][1]=bol[0]+'0';
		 for(int i=1;i<pos;i++)
		 {
			 
			 while(1)
			 {
				xx=x+dir[ff][0];
				yy=y+dir[ff][1];
				if(mp[xx][yy]==0&&xx>0&&xx<=r&&yy>0&&yy<=c)
				{
					mp[xx][yy]=bol[i]+'0';
					x=xx;
					y=yy;
					break;
				}
				else 
				{
					ff=(ff+1)%4;
				}
			 }
		 }
		 printf("%d ",cas++);
		 for(int i=1;i<=r;i++)
		 {
			 for(int j=1;j<=c;j++)
			 {
				 if(mp[i][j]==0)
					 mp[i][j]='0'; 
			 }
		 }
		 for(int i=1;i<=r;i++)
		 {
			 mp[i][c+1]=0;
			 printf("%s",mp[i]+1);
		 }
		 puts("");
	}
	
	return 0;
}







zoj zju 2989 Encoding 字符串处理