首页 > 代码库 > HDU4278Faulty Odometer

HDU4278Faulty Odometer

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4278


Faulty Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1154    Accepted Submission(s): 801


Problem Description
  You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one‘s, the ten‘s, the hundred‘s, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
 

Input
  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
 

Output
  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car. 
 

Sample Input
15 2005 250 1500 999999 0
 

Sample Output
15: 12 2005: 1028 250: 160 1500: 768 999999: 262143
 

Source
2012 ACM/ICPC Asia Regional Tianjin Online
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:  4267 4268 4269 4270 4271 


题意:统计从1~n除去含有‘3’‘8’数字外所有的数字的个数。


#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <cstdlib>
#include <climits>
#include <ctype.h>
#include <queue>
#include <stack>
#include <vector>
#include <deque>
#include <set>
#include <map>
#include <iostream>
#include <algorithm>
using namespace std;
#define PI acos(-1.0)
#define INF 0xffffff
int main()
{
	char a[47],b[47];
	int i , j ,len;
	__int64 sum,k;
	while( scanf("%s",a))
	{
		if(a[0] == ‘0‘)
			break;
		strcpy(b,a);
		sum = 0;
		len = strlen(a);
		for(i = 0 ;i < len ; i++)
		{
			if(a[i] > ‘8‘) 
				a[i] =a[i] - 2;
			else if(a[i] > ‘3‘)
				a[i] = a[i] - 1;
			k = pow(8,len-i-1);
			sum += (a[i]-‘0‘) * k;
		}
		printf("%s: %I64d\n",b,sum);
	}
	return 0;
}