首页 > 代码库 > HDU5112

HDU5112

A Curious Matt

Time Limit: 2000/2000 MS (Java/Others)    Memory Limit: 512000/512000 K (Java/Others)
Total Submission(s): 289    Accepted Submission(s): 189


Problem Description

There is a curious man called Matt.

One day, Matt‘s best friend Ted is wandering on the non-negative half of the number line. Matt finds it interesting to know the maximal speed Ted may reach. In order to do so, Matt takes records of Ted’s position. Now Matt has a great deal of records. Please help him to find out the maximal speed Ted may reach, assuming Ted moves with a constant speed between two consecutive records.


Input

The first line contains only one integer T, which indicates the number of test cases.

For each test case, the first line contains an integer N (2 ≤ N ≤ 10000),indicating the number of records.

Each of the following N lines contains two integers ti and xi (0 ≤ ti, xi ≤ 106), indicating the time when this record is taken and Ted’s corresponding position. Note that records may be unsorted by time. It’s guaranteed that all ti would be distinct.


Output

For each test case, output a single line “Case #x: y”, where x is the case number (starting from 1), and y is the maximal speed Ted may reach. The result should be rounded to two decimal places.


Sample Input

2 3 2 2 1 1 3 4 3 0 3 1 5 2 0


Sample Output

Case #1: 2.00 Case #2: 5.00
Hint
In the ?rst sample, Ted moves from 2 to 4 in 1 time unit. The speed 2/1 is maximal. In the second sample, Ted moves from 5 to 0 in 1 time unit. The speed 5/1 is maximal.


Source

2014ACM/ICPC亚洲区北京站-重现赛(感谢北师和上交)

题意其实很简单,每秒的位移不同,求每秒移动的最大速度。上代码吧。

#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <math.h>
#define wbx 10000000
using namespace std;
struct node
{
    int s,t;
}
a[wbx];
bool cmp(node a,node b)
{
    return a.t<b.t;
}
int max(int c,int d)
{
    return c>d?c:d;
}
int main()
{
    int n,i,cc=1;
    scanf("%d",&n);
    while(n--)
    {
        int m;
        scanf("%d",&m);
        for(i=0;i<m;i++)
            scanf("%d%d",&a[i].t,&a[i].s);
        sort(a,a+m,cmp);
        double sum;
        for(i=1,sum=0.0;i<m;i++)
                 sum=max(sum,abs(a[i].s-a[i-1].s)*1.0/(a[i].t-a[i-1].t));
//注意精度之类的要对好0.0。        printf("Case #%d: %.2lf\n",cc++,sum);
    }
    return 0;
}


 

HDU5112