首页 > 代码库 > hdoj-1289-A Bug's Life【种类并查集】

hdoj-1289-A Bug's Life【种类并查集】

A Bug‘s Life

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11386 Accepted Submission(s): 3709


Problem Description
Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output
The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs‘ sexual behavior, or "Suspicious bugs found!" if Professor Hopper‘s assumption is definitely wrong.

Sample Input
2 3 3 1 2 2 3 1 3 4 2 1 2 3 4

Sample Output
Scenario #1: Suspicious bugs found! Scenario #2: No suspicious bugs found!
Hint
Huge input,scanf is recommended.

Source

field=problem&key=TUD+Programming+Contest+2005%2C+Darmstadt%2C+Germany&source=1&searchmode=source">TUD Programming Contest 2005, Darmstadt, Germany


Recommend
linle | We have carefully selected several similar problems for you:

pid=1558" target="_blank">1558

pid=1811" target="_blank">1811

pid=1325" target="_blank">1325 2473 3172



#include<stdio.h>
int root[2010];
int rank[2010];
int find_set(int x){
	if(root[x]==x) return x;
	int t=root[x];
	root[x]=find_set(t);
	rank[x]=(rank[x]+rank[t])%2;
	return root[x];
}
void unio(int a,int b){
	int  t,k;
	t=root[a];
	k=root[b];
	root[t]=k;
	rank[t]=(rank[b]+1-rank[a]);
	return ;
}
int main(){
	int t,cas=0;;
	scanf("%d",&t);
	while(t--){
		printf("Scenario #%d:\n",++cas);
		int n,m,i,ok=0,a,b;
		scanf("%d%d",&n,&m);
		for(i=0;i<=n;++i){
			root[i]=i;
			rank[i]=0;
		}
		for(i=0;i<m;++i){
			scanf("%d%d",&a,&b);  
			if(!ok){
				int pa,pb;
				pa=find_set(a) ;
				pb=find_set(b);
				if(pa==pb&&(rank[a]==rank[b])){
					ok=1;
				}
				else
				unio(a,b);
			}	
		}
		if(ok)
		printf("Suspicious bugs found!\n\n");
		else
		printf("No suspicious bugs found!\n\n");
		
	}
	return 0;
}



hdoj-1289-A Bug&#39;s Life【种类并查集】