首页 > 代码库 > 指针当形参
指针当形参
Problem : 指针当形参
Description
下面的程序将调用函数进行变量的交换,请设计出交换的函数
#include <iostream>
using namespace std;
void jiaohuan(int *p1, int *p2);
int main( )
{
int a,b;
cin>>a>>b;
jiaohuan(&a,&b);
cout<<a<<" "<<b<<endl;
return 0;
}
//下面定义jiaohuan;
Input
两个整数
Output
输入数据交换顺序后的结果
Sample Input
100 10
Sample Output
10 100
/* *Copyright(c)2014,烟台大学计算机学院 *All rights reserved. *文件名称:test.cpp *作者: 杨汉宁 *完成日期:2014年 12月 8日 *版本号:v1.0 * *问题描述:用指针交换两数 *程序输入: *程序输出: */ #include <iostream> using namespace std; void FX(int *p1, int *p2); int main( ) { int a,b; cin>>a>>b; FX(&a,&b); cout<<a<<" "<<b<<endl; return 0; } void FX(int *p1, int *p2) { int *temp; temp=new int; *temp=*p1; *p1=*p2; *p2=*temp; delete temp; }
指针当形参
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。