首页 > 代码库 > hdu 1005 找循环节

hdu 1005 找循环节

Number Sequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others) Total Submission(s): 111101    Accepted Submission(s): 26982

Problem Description
A number sequence is defined as follows:
f(1) = 1, f(2) = 1, f(n) = (A * f(n - 1) + B * f(n - 2)) mod 7.
Given A, B, and n, you are to calculate the value of f(n).
 

 

Input
The input consists of multiple test cases. Each test case contains 3 integers A, B and n on a single line (1 <= A, B <= 1000, 1 <= n <= 100,000,000). Three zeros signal the end of input and this test case is not to be processed.
 

 

Output
For each test case, print the value of f(n) on a single line.
 

 

Sample Input
1 1 3
1 2 10
0 0 0
 

 

Sample Output
2
5
 
 
 
                      ps:本按正常思路写,发现超时。。然后就输数据。。发现原来还有循环。。也就是说找到相对应的循环节就好
#include "stdio.h"
int main()
{
 int a,b,n,f[100],i;
 while(~scanf("%d%d%d",&a,&b,&n)&&a&&b&&n)
 {
  f[1]=1;f[2]=1;
  for(i=3;i<100;i++)
  {
   f[i]=(a*f[i-1]+b*f[i-2])%7;
   if(f[i-1]==1&&f[i]==1)
   break;
  }
  i-=2;
   if(n%i!=0)
   printf("%d\n",f[n%i]);
   else
   printf("%d\n",f[i]);
 }
 return 0;
}
 

hdu 1005 找循环节