首页 > 代码库 > 九度 题目1154:Jungle Roads

九度 题目1154:Jungle Roads

题目描述:

   

    The Head Elder of the tropical island of Lagrishan has a problem. A burst of foreign aid money was spent on extra roads between villages some years ago. But the jungle overtakes roads relentlessly, so the large road network is too expensive to maintain. The Council of Elders must choose to stop maintaining some roads. The map above on the left shows all the roads in use now and the cost in aacms per month to maintain them. Of course there needs to be some way to get between all the villages on maintained roads, even if the route is not as short as before. The Chief Elder would like to tell the Council of Elders what would be the smallest amount they could spend in aacms per month to maintain roads that would connect all the villages. The villages are labeled A through I in the maps above. The map on the right shows the roads that could be maintained most cheaply, for 216 aacms per month. Your task is to write a program that will solve such problems.

输入:

    The input consists of one to 100 data sets, followed by a final line containing only 0. Each data set starts with a line containing only a number n, which is the number of villages, 1 < n < 27, and the villages are labeled with the first n letters of the alphabet, capitalized. Each data set is completed with n-1 lines that start with village labels in alphabetical order. There is no line for the last village. Each line for a village starts with the village label followed by a number, k, of roads from this village to villages with labels later in the alphabet. If k is greater than 0, the line continues with data for each of the k roads. The data for each road is the village label for the other end of the road followed by the monthly maintenance cost in aacms for the road. Maintenance costs will be positive integers less than 100. All data fields in the row are separated by single blanks. The road network will always allow travel between all the villages. The network will never have more than 75 roads. No village will have more than 15 roads going to other villages (before or after in the alphabet). In the sample input below, the first data set goes with the map above.

输出:

    The output is one integer per line for each data set: the minimum cost in aacms per month to maintain a road system that connect all the villages. Caution: A brute force solution that examines every possible set of roads will not finish within the one minute time limit.

样例输入:
9
A 2 B 12 I 25
B 3 C 10 H 40 I 8
C 2 D 18 G 55
D 1 E 44
E 2 F 60 G 38
F 0
G 1 H 35
H 1 I 35
3
A 2 B 10 C 40
B 1 C 20
0

样例输出:

216

30

用并查集解决,代码如下:

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
#include <stdio.h>
#include <iostream>
#include <algorithm>
#include <math.h>
usingnamespace std;
 
intfin[27];
 
structedge{
    intstart;
    intend;
    intvalue;
}eg[900];
 
intfind(inta){
    if(fin[a] == a){
        returna;
    }
    returnfind(fin[a]);
}
 
voidMerge(inta, intb){
    a = find(a);
    b = find(b);
    fin[a] = fin[b];
}
 
boolcmp(edge e1, edge e2){
    returne1.value < e2.value;
}
 
intmain(){
    intn;
    while(scanf("%d",&n) != EOF && n != 0){
        intindex = 0;
        for(inti = 0; i < n-1; i++){
            fin[i] = i;
            charch;
            intnum;
            //scanf("%c %d",&ch,&num);
            cin>>ch>>num;
            for(intj = 0; j < num; j++){
                charch2;
                intvalue;
                //scanf("%c %d",&ch2,&value);
                cin>>ch2>>value;
                eg[index].start = i;
                eg[index].end = ch2 - ‘A‘;
                eg[index].value = http://www.mamicode.com/value;
                index++;
            }
        }
        fin[n-1] = n-1;
        sort(eg,eg+index,cmp);
        intsum = 0;
        for(inti = 0; i < index; i++){
            inta = eg[i].start;
            intb = eg[i].end;
            if(find(a) != find(b)){
                Merge(a,b);
                sum = sum + eg[i].value;
            }
        }
        //printf("%d\n",sum);
        cout<<sum<<endl;
    }
    return0;
}
 
/**************************************************************
    Problem: 1154
    User: 姜超
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1528 kb
***************************************************************/
一开始用的scanf("%c %d",&ch,&num),这样的话是错误的,要么改成scanf(" %c %d",&ch,&num),即在%c前面加上个空格;要么在之前加一个getchar();就行了。至于原因很简单,因为第一个输入时字符,循环输入的时候,本次的空格会被当成下一次的字符输入,所以要用getchar()吃掉多余的空格,或者是%c之前加一个空格!

九度 题目1154:Jungle Roads