首页 > 代码库 > 排序训练5, B-2

排序训练5, B-2

Excel可以对一组纪录按任意指定列排序。现请你编写程序实现类似功能。
 

Input

测试输入包含若干测试用例。每个测试用例的第1行包含两个整数 N (<=100000) 和 C,其中 N 是纪录的条数,C 是指定排序的列号。以下有 N 
行,每行包含一条学生纪录。每条学生纪录由学号(6位数字,同组测试中没有重复的学号)、姓名(不超过8位且不包含空格的字符串)、成绩(闭区间[0, 100]内的整数)组成,每个项目间用1个空格隔开。当读到 N=0 时,全部输入结束,相应的结果不要输出。 
 

Output

对每个测试用例,首先输出1行“Case i:”,其中 i 是测试用例的编号(从1开始)。随后在 N 行中输出按要求排序后的结果,即:当 C=1 时,按学号递增排序;当 C=2时,按姓名的非递减字典序排序;当 C=3 
时,按成绩的非递减排序。当若干学生具有相同姓名或者相同成绩时,则按他们的学号递增排序。 
 

Sample Input

3 1000007 James 85000010 Amy 90000001 Zoe 604 2000007 James 85000010 Amy 90000001 Zoe 60000002 James 984 3000007 James 85000010 Amy 90000001 Zoe 60000002 James 900 0
 

Sample Output

Case 1:000001 Zoe 60000007 James 85000010 Amy 90Case 2:000010 Amy 90000002 James 98000007 James 85000001 Zoe 60Case 3:000001 Zoe 60000007 James 85000002 James 90000010 Amy 90

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct stu //定义结构体
{
int z;
char x[7],y[9];
}st[100000];
bool cam1(stu a,stu b) //对学号排序
{
return strcmp(a.x,b.x)<0;
}
bool cam2(stu a,stu b) //对姓名排序
{
if(strcmp(a.y,b.y)==0)
return strcmp(a.x,b.x)<0;
return strcmp(a.y,b.y)<0;
}
bool cam3(stu a,stu b) //对成绩排序
{
if(a.z==b.z)
return strcmp(a.x,b.x)<0;
return a.z<b.z;
}
int main()
{
int n,c,d,i,t,cas=1,sum;
while(~scanf("%d%d",&n,&c))
{
i=0;t=n;sum=0;
while(n--)
{
scanf("%s%s%d",&st[i].x,&st[i].y,&st[i].z);
if(strlen(st[i].x)<=6&&strlen(st[i].y)<=8&&0<=st[i].z&&st[i].z<=100) //判断输入值是否满足需求
sum++;
i++;
}
if(sum==i&&t!=0&&0<c<4)
{
sort(st,st+t,cam1);
for(d=0,i=0;i<t-1;i++)
if(strcmp(st[i].x,st[i+1].x)==0) //排除学号相同的错误情况。
d=1;
if(d==0)
{
if(c==2)
{
sort(st,st+t,cam2);
}
if(c==3)
{
sort(st,st+t,cam3);
}
printf("Case %d:\n",cas++);
for(i=0;i<t;i++)
printf("%s %s %d\n",st[i].x,st[i].y,st[i].z);
}
}
}
return 0;
}

心得:对于结构体的更进一步熟悉和使用,错误的很多次让我更加注意题目所给出的条件。

排序训练5, B-2