首页 > 代码库 > 第一轮 F

第一轮 F

Multiple of 17Time Limit:1000MS     Memory Limit:0KB     64bit IO Format:%lld & %lluSubmit StatusDescriptionDownload as PDF  Multiple of 17 Theorem: If you drop the last digit d of an integer n (n$ \ge$10), subtract 5d from the remaining integer, then the difference is a multiple of 17 if and only if n is a multiple of 17.For example, 34 is a multiple of 17, because 3-20=-17 is a multiple of 17; 201 is not a multiple of 17, because 20-5=15 is not a multiple of 17.Given a positive integer n, your task is to determine whether it is a multiple of 17.Input There will be at most 10 test cases, each containing a single line with an integer n ( 1$ \le$n$ \le$10100). The input terminates with n = 0, which should not be processed.Output For each case, print 1 if the corresponding integer is a multiple of 17, print 0 otherwise.Sample Input 34201209876541317171717171717171717171717171717171717171717171717180Sample Output 1010Problemsetter: Rujia Liu, Special Thanks: Yiming Li/*************************************************************************
	> File Name: f.cpp
	> Author:yuan 
	> Mail: 
	> Created Time: 2014年11月09日 星期日 13时04分13秒
 ************************************************************************/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<algorithm>
#include<cmath>
using namespace std;
int mat[105];
char str[105];
int ans;
int main()
{
    while(1){
        scanf("%s",str);
        if(str[0]=='0') break;
        int l=strlen(str);
        for(int i=0;i<l;i++)
        {
            mat[i]=str[i]-'0';
        }
        ans=0;
        for(int i=0;i<l-1;i++)
        {
            ans=ans*10+mat[i];
            ans=ans%17;
        }
        ans=(ans-mat[l-1]*5)%17;
        if(ans==0) printf("1\n");
        else printf("0\n");
    }
    return 0;
}

第一轮 F