首页 > 代码库 > poj 1700 Crossing River

poj 1700 Crossing River

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 10218 Accepted: 3859

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won‘t be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17

贪心算法:

1. 若n=1、2,一次过完。

2. n=3,由过桥最短的挨个把其他人送过河。

4、n>=4,

设用时分别为a,b,c,d,e,f...y,z(从小到大排序)

有两种策略,一种是由用时最短的人把用时最多的两个人挨个送过河,时间为2*a+y+z;

第二种: a,b先过河,a 回,然后y,z过河,b回,时间为:b+a+z+b=a+2*b+z;

比较两种方法的用时,最终得到最优答案。


#include"stdio.h"
#include"stdlib.h"
#define N 1005
int cmp(const void*a,const void*b)
{
    return *(int*)a-*(int *)b;
}
int main()
{
    int T,n,i,a[N],time;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%d",&a[i]);
        }
        qsort(a,n,sizeof(a[0]),cmp);
        time=0;
        while(1)
        {
            if(n==1)
            {
                time+=a[0];
                break;
            }
            else if(n==2)
            {
                time+=a[1];
                break;
            }
            else if(n==3)
            {
                time+=(a[0]+a[1]+a[2]);
                break;
            }
            if(a[1]*2>a[0]+a[n-2])
            {
                time+=(a[n-1]+a[n-2]+2*a[0]);
                n-=2;
            }
            else
            {
                time+=(2*a[1]+a[n-1]+a[0]);
                n-=2;
            }
        }
        printf("%d\n",time);
    }
    return 0;
}