首页 > 代码库 > UVA 10815-Andy's First Dictionary(字符串模拟+排序+重复删除)

UVA 10815-Andy's First Dictionary(字符串模拟+排序+重复删除)

Andy‘s First Dictionary
Time Limit:3000MS     Memory Limit:0KB     64bit IO Format:%lld & %llu
Submit Status

Description

技术分享

Problem B: Andy‘s First Dictionary

Time limit: 3 seconds


技术分享

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful.

You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive sequence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe InSeNsItIvE. For example, words like "Apple", "apple" or "APPLE" must be considered the same.

Input

The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF.

Output

Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland

Two blondes were going to Disneyland when they came to a fork in the
road. The sign read: "Disneyland Left."

So they went home.

Sample Output

a
adventures
blondes
came
disneyland
fork
going
home
in
left
read
road
sign
so
the
they
to
two
went
were
when

题意:将输入的单词按照字典序排序,删除重复的。

注意数组大小是5000*200。

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
#include <iostream>
#include <string>
using namespace std;
char str[10010];
string a[1000010];
int main()
{
    int i;
    int flag;
    int cnt=-1;
    while(gets(str))
    {
        flag=0;//用来标记当前输入是字母还是其他;
        for(i=0; str[i]!='\0'; i++)
        {
            if(str[i]>='a'&&str[i]<='z')
            {
                if(!flag)
                    {
                    cnt++;
                    a[cnt]=str[i];
                    flag=1;
                    }
                else
                {
                    a[cnt]=a[cnt]+str[i];
                }
            }
            else if(str[i]>='A'&&str[i]<='Z')
                if(!flag)
                {
                    cnt++;
                    str[i]=str[i]+32;
                    a[cnt]=str[i];
                    flag=1;
                }
                else
                {
                    str[i]=str[i]+32;
                    a[cnt]=a[cnt]+str[i];
                }
            else
                flag=0;
        }
    }
    sort(a,a+cnt+1);
    cout<<a[0]<<endl;
    for(i=1; i<=cnt; i++)
    {
        if(a[i]!=a[i-1])
        {
            cout<<a[i]<<endl;
        }
    }
    return 0;
}


UVA 10815-Andy's First Dictionary(字符串模拟+排序+重复删除)