首页 > 代码库 > HDU1985 Conversions【水题】

HDU1985 Conversions【水题】

Conversions


Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1674    Accepted Submission(s): 986

Problem Description
Conversion between the metric and English measurement systems is relatively simple. Often, it involves either multiplying or dividing by a constant. You must write a program that converts between the following units:
技术分享


Input

The first line of input contains a single integer N, (1 ≤ N ≤ 1000) which is the number of datasets that follow.
Each dataset consists of a single line of input containing a floating point (double precision) number, a space and the unit specification for the measurement to be converted. The unit specification is one of kg, lb, l, or g referring to kilograms, pounds, liters and gallons respectively.
 
Output
For each dataset, you should generate one line of output with the following values: The dataset number as a decimal integer (start counting at one), a space, and the appropriately converted value rounded to 4 decimal places, a space and the unit specification for the converted value.

Sample Input
5
1 kg
2 l
7 lb
3.5 g
0 l
 
Sample Output
1 2.2046 lb
2 0.5284 g
3 3.1752 kg
4 13.2489 l
5 0.0000 g
 
Source

2008 “Shun Yu Cup” Zhejiang Collegiate Programming Contest - Warm Up(1)


题目大意:国际度量制度和英国度量制度之间的转换。

思路:水题。2015年第一道题,希望新的一年继续努力,得到更多的收获。


#include<iostream>
#include<string>
#include<stdio.h>
#include<algorithm>
using namespace std;

int main()
{
    int N;
    double a;
    string s;
    cin >> N;
    for(int i = 1; i <= N; ++i)
    {
        cin >> a >> s;
        printf("%d ",i);
        if(s == "kg")
            printf("%.4lf lb\n",2.2046*a);
        else if(s == "l")
            printf("%.4lf g\n",0.2642*a);
        else if(s == "lb")
            printf("%.4lf kg\n",a*0.4536);
        else if(s == "g")
            printf("%.4lf l\n",a*3.7854);
    }
    return 0;
}


HDU1985 Conversions【水题】