首页 > 代码库 > SOJ.Alice and Bob
SOJ.Alice and Bob
1798. Alice and Bob
Description
Bob is very famous because he likes to play games. Today he puts a chessboard in the desktop, and plays a game with Alice. The size of the chessboard is n by n. A stone is placed in a corner square. They play alternatively with Alice having the first move. Each time, player is allowed to move the stone to an unvisited neighbor square horizontally or vertically. The one who can’t make a move will lose the game. If both play perfectly, who will win the game?Input
The input is a sequence of positive integers each in a separate line. The integers are between 1 and 10000, inclusive, indicating the size of the chessboard. The end of the input is indicated by a zero.
Output
Output the winner (“Alice” or “Bob”) for each input line except the last zero. No other characters should be inserted in the output.
Sample Input
2 0
Sample Output
Alice
01.
// Problem#: 13417
02.
// Submission#: 3529776
03.
// The source code is licensed under Creative Commons Attribution-NonCommercial-ShareAlike 3.0 Unported License
04.
// URI:http://creativecommons.org/licenses/by-nc-sa/3.0/
05.
// All Copyright reserved by Informatic Lab of Sun Yat-sen University
06.
#include<iostream>
07.
using
namespace
std;
08.
int
main()
09.
{
10.
int
n;
11.
while
(cin>>n,n!=0)
12.
{
13.
if
(n%2==0)
14.
cout<<
"Alice"
<<endl;
15.
else
16.
cout<<
"Bob"
<<endl;
17.
}
18.
}
水成狗啊~
SOJ.Alice and Bob