首页 > 代码库 > poj 2528 Mayor's posters(线段树+hash_map离散化)

poj 2528 Mayor's posters(线段树+hash_map离散化)

Mayor‘s posters
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 45444 Accepted: 13194

Description

The citizens of Bytetown, AB, could not stand that the candidates in the mayoral election campaign have been placing their electoral posters at all places at their whim. The city council has finally decided to build an electoral wall for placing the posters and introduce the following rules: 
  • Every candidate can place exactly one poster on the wall. 
  • All posters are of the same height equal to the height of the wall; the width of a poster can be any integer number of bytes (byte is the unit of length in Bytetown). 
  • The wall is divided into segments and the width of each segment is one byte. 
  • Each poster must completely cover a contiguous number of wall segments.

They have built a wall 10000000 bytes long (such that there is enough place for all candidates). When the electoral campaign was restarted, the candidates were placing their posters on the wall and their posters differed widely in width. Moreover, the candidates started placing their posters on wall segments already occupied by other posters. Everyone in Bytetown was curious whose posters will be visible (entirely or in part) on the last day before elections. 
Your task is to find the number of visible posters when all the posters are placed given the information about posters‘ size, their place and order of placement on the electoral wall. 

Input

The first line of input contains a number c giving the number of cases that follow. The first line of data for a single case contains number 1 <= n <= 10000. The subsequent n lines describe the posters in the order in which they were placed. The i-th line among the n lines contains two integer numbers li and ri which are the number of the wall segment occupied by the left end and the right end of the i-th poster, respectively. We know that for each 1 <= i <= n, 1 <= li <= ri <= 10000000. After the i-th poster is placed, it entirely covers all wall segments numbered li, li+1 ,... , ri.

Output

For each input data set print the number of visible posters after all the posters are placed. 

The picture below illustrates the case of the sample input. 
技术分享

Sample Input

1
5
1 4
2 6
8 10
3 4
7 10

Sample Output

4

Source

Alberta Collegiate Programming Contest 2003.10.18

[Submit]   [Go Back]   [Status]   [Discuss]

技术分享Home Page   技术分享Go Back  技术分享To top


题意:

n次输入,每次输入一段区间,代表一张海报,会覆盖之前贴的,求最后能看到的海报数。


题解:

线段树,吧每段区间标记成一个数,最后查询不同数的个数。数据过大,得离散化。


CODE:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>
#include<hash_map>

#define N 10010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const int INF = 1000010;

using namespace std;
//using namespace __gnu_cxx;
using namespace stdext;


int col[N<<4],num[N*4];
bool vis[N*4];
int n,ans;
struct node
{
    int l;
    int r;
} a[N];

void push_down(int idx)
{
    if(col[idx])
    {
        col[lc]=col[rc]=col[idx];
        col[idx]=0;
    }
}

void update(int l,int r,int idx,int x,int y,int k)
{
    if(x<=l&&y>=r)
    {
        col[idx]=k;
        return;
    }
    push_down(idx);
    int mid=(l+r)>>1;
    if(x<=mid)
        update(lson,x,y,k);
    if(y>mid)
        update(rson,x,y,k);
}

void query(int l,int r,int idx)
{
    if(col[idx])
    {
        if(!vis[col[idx]])
            ans++;
        vis[col[idx]]=1;
        return;
    }
    if(r==l)
        return;
    push_down(idx);
    int mid=(l+r)>>1;
    query(lson);
    query(rson);
}

int main()
{
    int t;
    scanf("%d",&t);
    {
        while(t--)
        {
            scanf("%d",&n);
            int m=1;
            for(int i=1; i<=n; i++)
            {
                scanf("%d%d",&a[i].l,&a[i].r);
                num[m++]=a[i].l;
                num[m++]=a[i].r;
            }
            sort(num+1,num+m);
            int len=1;
            hash_map<int,int>p;
            p[num[1]]=len++;
            for(int i=2; i<m; i++)
                if(num[i]!=num[i-1])
                    p[num[i]]=len++;
            //len--;
            memset(vis,0,sizeof vis);
            memset(col,0,sizeof col);
            for(int i=1; i<=n; i++)
                update(1,len,1,p[a[i].l],p[a[i].r],i);
            ans=0;
            query(1,len,1);
            printf("%d\n",ans);
        }
    }
    return 0;
}



poj 2528 Mayor's posters(线段树+hash_map离散化)