首页 > 代码库 > NYOJ 题目94 cigarettes
NYOJ 题目94 cigarettes
题目描述:
Tom has many cigarettes. We hypothesized that he has n cigarettes and smokes them
one by one keeping all the butts. Out of k > 1 butts he can roll a new cigarette.
Now,do you know how many cigarettes can Tom has?
- 输入
- First input is a single line,it‘s n and stands for there are n testdata.then there are n lines ,each line contains two integer numbers giving the values of n and k.
- 输出
- For each line of input, output one integer number on a separate line giving the maximum number of cigarettes that Peter can have.
- 样例输入
-
3 4 3 10 3 100 5
- 样例输出
-
5 14 124
大致意思是假设汤姆有n支香烟,每吸k支香烟就会得到一支新的香烟,求汤姆最多能吸多少支香烟?#include<stdio.h>
int main()
{
int N;
scanf("%d",&N);
while(N--)
{
int n,k,i;
int sum=0;
scanf("%d %d",&n,&k);
for(i=1;i<=n;i++)
{
sum=sum+1;
if(sum%k==0)
n=n+1;
}
printf("%d",sum);
printf("\n");
}
}//AC
欢迎各路大神评论!
NYOJ 题目94 cigarettes
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。