首页 > 代码库 > ZOJ 2853 Evolution[ 矩阵快速幂 ]

ZOJ 2853 Evolution[ 矩阵快速幂 ]

传送门:ZOJ 1853

Description

Evolution is a long, long process with extreme complexity and involves many species. Dr. C. P. Lottery is currently investigating a simplified model of evolution: consider that we haveN (2 <= N <= 200) species in the whole process of evolution, indexed from 0 toN -1, and there is exactly one ultimate species indexed as N-1. In addition, Dr. Lottery divides the whole evolution process intoM (2 <= M <= 100000) sub-processes. Dr. Lottery also gives an ‘evolution rate‘P(i, j) for 2 species i and j, where i and j are not the same, which means that in an evolution sub-process,P(i, j) of the population of species i will transform to speciesj, while the other part remains unchanged.

Given the initial population of all species, write a program for Dr. Lottery to determine the population of the ultimate species after the evolution process. Round your final result to an integer.

Input

The input contains multiple test cases!

Each test case begins with a line with two integers N, M. After that, there will be a line withN numbers, indicating the initial population of each species, then there will be a numberT and T lines follow, each line is in format "i j P(i,j)" (0 <=P(i,j) <=1).

A line with N = 0 and M = 0 signals the end of the input, which should not be proceed.

Output

For each test case, output the rounded-to-integer population of the ultimate species after the whole evolution process. Write your answer to each test case in a single line.

Notes

  • There will be no ‘circle‘s in the evolution process.
  • E.g. for each species i, there will never be a path i, s1, s2, ..., st, i, such thatP(i,s1) <> 0, P(sx,sx+1) <> 0 and P(st, i) <> 0.
  • The initial population of each species will not exceed 100,000,000.
  • There‘re totally about 5 large (N >= 150) test cases in the input.

Example

Let‘s assume that P(0, 1) = P(1, 2) = 1, and at the beginning of a sub-process, the populations of 0, 1, 2 are 40, 20 and 10 respectively, then at the end of the sub-process, the populations are 0, 40 and 30 respectively.

Sample Input

2 3
100 20
1
0 1 1.0
4 100
1000 2000 3000 0
3
0 1 0.19
1 2 0.05
0 2 0.67
0 0

Sample Output

120
0


题目大意:总体是一个进化的过程,共有n个物种,p(i,j)表示一轮进化中i->j转化的比例,问装化m轮后第n个物种的个数。


思路:因为每轮都是对整个物种的数组进行乘法,然后加起来,正好用矩阵乘法。然后用快速幂加速。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>

using namespace std;

const int N=250;
int n;
struct Mat{
	double mat[N][N];
};

Mat operator *(Mat a,Mat b)
{

	Mat c;
	memset(c.mat,0,sizeof(c.mat));
	for(int k=0;k<n;k++){

		for(int i=0;i<n;i++){

			if(a.mat[i][k]<=0) continue;  //优化
			for(int j=0;j<n;j++){

				if(b.mat[k][j]<=0) continue;
				c.mat[i][j]+=a.mat[i][k]*b.mat[k][j];
			}
		}
	}
	return c;
}

Mat operator ^ (Mat a,int k)
{

	Mat c;
	for(int i=0;i<n;i++){
		for(int j=0;j<n;j++){
			c.mat[i][j]=(i==j);  //初始化为单位矩阵
		}
	}
	while(k)
	{
		if(k&1) c=c*a;
		a=a*a;
		k>>=1;
	}
    return c;

}
int main()
{
	int m;
	//freopen("in.txt","r",stdin);
	while(scanf("%d%d",&n,&m),n||m)
	{
		Mat species,p;
		for(int i=0;i<n;i++)
			for(int j=0;j<n;j++)
				p.mat[i][j]=(i==j);
		for(int i=0;i<n;i++)
			scanf("%lf",&species.mat[i][0]);
		int nn;
		scanf("%d",&nn);
		int j,k;
		double v;
		for(int i=0;i<nn;i++)
		{
			cin>>j>>k>>v;
			p.mat[k][j]+=v;
			p.mat[j][j]-=v;
		}
		
		p=p^m;
		species=p*species;
		printf("%.0f\n",species.mat[n-1][0]);
		//cout<<"----"<<endl;
	}
	return 0;
}


ZOJ 2853 Evolution[ 矩阵快速幂 ]