首页 > 代码库 > 下一代互联网技术(路由配置)
下一代互联网技术(路由配置)
下一代互联网技术:
2016.10.6
一、ipv6静态路由小结:
静态路由分为3类:
1.直连静态路由配置:(config)#ipv6 route 目标网段+本地送出接口
2.递归静态路由配置:(config)#ipv6 route 目标网段+下一跳地址
3.完全静态路由配置:(config)#ipv6 route 目标网段+本地送出接口+下一跳地址
还有相关命令:
#show ipv6 interface
#show ipv6 route
#show ipv6 neighbors
(config)#interface loopback x(序号) 进环回接口
2016.10.7
二、ipv6 RIP配置小结:
1、配置基本rip:
(1)先在全局模式下声明配置某RIPng进程。注:cisco ios 仅支持4个RIPng进程,各进程通过名字区分
(config)#ipv6 unicast-routing
(config)#ipv6 router rip xxx(Rip进程名)
(2)再在相关接口下指定对应的RIPng进程。
(config)#int fx/x
(config-if)#ipv6 rip xxx enable
2、重分布ipv6网段:(将剩余的网段重分布进RIPng)
(config)# route-map xxx(自定义名) permit x (自定义序号)
(config-route-map)# match interface f x/x(接口号)
//以上命令可根据要接入的网段数重复n条,自定义序号无关联。
(config)# ipv6 router rip xxx(Rip进程名)
(config-rtr)#redistribute connected route-map xxx
//进入相应的rip进程中重分布路由
3、过滤ipv6路由:(只想保留想要的网段,通过distribute-list过滤)
(config)# ipv6 prefix-list xxx(列名) permit xxxxxxx(欲留网段)
(config)# ipv6 router rip xxx(Rip进程名)
(config-rtr)# distribute-list prefix-list xxx(列名) in fx/x(接口)(下一跳接口)
2016.10.8
三、ipv6 OSPF配置小结:
1、配置基本ospf:
(1)声明配置某OSPF进程。
(config)#ipv6 unicast-routing
(config)#ipv6 router ospf x(ospf进程号)
(config-rtr)#router-id x.x.x.x(ipv4地址)
(2)再在相关接口下指定对应的OSPF进程。
(config)#int f x/x
(config-if)#ipv6 ospf x area x(区号)
2、重分布ipv6网段:(将剩余的网段重分布进ospf)
(config)# route-map abc(自定义名) permit x(自定义序号)
(config-route-map)# match interface f x/x(接口号)
//以上命令可根据要接入的网段数重复n条,自定义序号无关联。
(config)# ipv6 router ospf xxx(ospf进程名)
(config-rtr)# redistribute connected route-map abc(自定义名)
//进入相应的ospf进程中重分布路由
3、过滤ipv6路由:(只想保留想要的网段,通过distribute-list过滤)
(config)#ipv6 prefix-list xxx(列名) permit xxxxxxx/x(欲留网段)
(config)#ipv6 router ospf xxx(ospf进程名)
(config-rtr)# distribute-list prefix-list xxx(列名) in f x/x(接口)(下一跳接口)
4.汇总ospf外部路由
(config)#ipv6 router ospf x
(config-rtr)#summary-prefix x:x:x::/x(类似ipv4多条路由汇总所得最大网段)
还有相关命令:
#show ipv6 ospf neighbor
#show ipv6 interface brief s|f x/x
#show ipv6 route ospf
5.若俩路由器间非以太网连接而是通过帧中继连接,则需配置两路由器连接帧中继的那端接口:
(config)#interface seri x/x
(config-if)#encapsulation frame-relay
(config-if)#no frame-relay inverse-arp
(config-if)#no arp frame-relay
(config-if)#ipv6 address x.x.x.x/x(本接口配置的ipv6/网络位)
(config-if)#frame-relay map ipv6 x.x.x.x(对端接口ipv6) xxx(本端接帧中继的DLCI) broadcast
6.解决ospf邻居问题:
法一:手工指定邻居
(1)只需一方在连接的接口下指定对方的链路本地地址
(config)#int seri x/x
(config-if)#ipv6 ospf neighbor x:x:x:x
(2)创建帧中继网络下双方接口的链路本地地址的PVC相互映射
(config-if)#fram map ipv6 x:x:x:x(对端链路本地地址) xxx(本端接帧中继的DLCI) broadcast
法二:将网络类型从非广播网络类改为允许广播网络类型,例如point-to-point类型
7.解决OSPF路由掩码问题:
属于loopback接口网段学到的为128位主机路由,与想要的掩码不一致,所以要将网络类型改为point-to-point类型
(config)#int loopback x
(config-if)#ipv6 ospf network point-to-point
四、ipv4 EIGRP配置小结:
(config)#ip routing
(config)#router eigrp x(自治系统区号)
(config-rtr)#network x.x.x.x(声明网段)
2016.10.12
IPv6 ERGIP配置小节:
1、配置基本eigrp:
(1)声明配置某eigrp进程。
(config)#ipv6 unicast-routing
(config)#ipv6 router eigrp x(自治区号)
(config-rtr)#router-id x.x.x.x(ipv4地址)
(config-rtr)#no shutdown //路由器默认关闭,必须手动开启!
(2)再在相关接口下指定对应的eigrp进程。
(config)#int f x/x
(config-if)#ipv6 eigrp x(区号)
2、重分布ipv6网段:(将剩余的网段重分布进eigrp)
(config)# route-map abc(自定义名) permit x(自定义序号)
(config-route-map)# match interface f x/x(接口号)
//以上命令可根据要接入的网段数重复n条,自定义序号无关联。
(config)# ipv6 router ergip x(区号)
(config-rtr)# redistribute connected route-map abc(自定义名)
//进入相应的eigrp进程中重分布路由
3、过滤ipv6路由:(只想保留想要的网段,通过distribute-list过滤)
(config)# ipv6 prefix-list xxx(列名) permit xxxxxxx/x(欲留网段)
(config)# ipv6 router eigrp x(区号)
(config-rtr)# distribute-list prefix-list xxx(列名) in f x/x(接口)(下一跳接口)
还有相关命令:
#show ipv6 eigrp neighors
#show ipv6 route eigrp
2016.10.12
IPv4_BGP配置小结:
1.给所有路由器接口配置ip
2.配置eigrp路由:
(config)#router eigrp x(自治区号)
(config-router)#network x.x.x.x(网段) x.x.x.x(掩码) //声明本所有网段
(config-router)#no auto-summary //关闭自动汇总
3.所有路由器启动BGP进程:
(config)#router bgp xxx(区号)
(config-router)#bgp router-id x.x.x.x //配置BGP路由器ID(本某端口已配置的ip)
(config-router)#neighbor x.x.x.x(邻居ip) remote-as xxx
//指定所有e/iBGP邻居路由器,及其所在bgp的AS区号
(config-router)#neighbor x.x.x.x(igrp邻居路由器) update-sourceloopback xxx (本某端口) //定制更新源
(config-router)#network x.x.x.x(网段) mask x.x.x.x(掩码)
//通告必要的bgp本网段,使网络可通告路由
(config-router)#no synchronization //关闭同步
(config-router)#no auto-summary //关闭自动汇总
(config-router)#neighbor x.x.x.x(EIGRP邻居ip) next-hop-self
//注:只有连接跨BGP区的路由器才需要配置,从而使本路由器作为发送BGP更新的下一跳,来通报给IBGP内部邻居。(即ebgp和ibgp中介)
相关命令:
#show tcp brief //查看使用BGP路由的TCP连接信息摘要
#show ip bgp neighbors //查看邻居的TCP和BGP连接的详细信息
#show ip bgp summary //查看BGP连接的摘要信息
#show ip bgp //查看BGP表的信息
#show ip route
#show bgp xxx(区号)
(config-router)#synchronization //打开同步
#clear ip bgp* //重置BGP连接
#show ip bgp
2016.10.20
BGP之地址聚合 //注:能地址聚合的前提是在BGP表中至少含有该聚合地址的一条明细路由
(1)地址聚合不带任何参数
(config)#router bgp x
(config-router)#aggregate-address x.x.x.x x.x.x.x(聚合网段及掩码)
//路由聚合后,则该聚合地址下的所有明细都会丢失
(2)地址聚合含as-set参数
(config)#router bgp x
(config-router)#aggregate-address x.x.x.x x.x.x.x(聚合网段及掩码) as-set
//带有as-set参数的路由聚合,其聚合地址下的所有明细都会保留
(3)地址聚合含summary-only参数
(config)#router bgp x
(config-router)#aggregate-address x.x.x.x x.x.x.x(聚合网段及掩码) summary-only
//
(4)地址聚合含suppress-map参数
2016.10.26
BGP之origin属性
(1)配置基础网路
(2)配置IGP,使同属区域的底层路由互相连通,例如用eigrp
(config)#router eigrp xxx(自治区) //自治区号必须相同
(config-router)#no auto-summary //关闭自动汇总
(config-router)#network x.x.x.x(网段) x.x.x.x(掩码) //声明所有网段,使区域内底层路由都可达
(3)配置EGP即BGP
(config)#router bgp xxx(bgp区号)
(config-router)#no autosummary
(config-router)#no synchronization //关闭同步
(config-router)#bgp router-id x.x.x.x(指定router-id的IP)
(config-router)#neighbor x.x.x.x(邻居ip) remote-as xxx(所属bgp区号)
(config-router)#neighbor x.x.x.x update-sourceloopback x
//更新源使用的端口
(config-router)#neighbor x.x.x.x next-hop-self
//以自己作为下一跳(只有该邻居和自己直连才设为自己)
(config-router)#network x.x.x.x(网段) mask x.x.x.x(掩码)
//声明必要网段,使bgp区域间路由可达
(4)配置bgp的origin属性
(config)#access-list xxx(accesslistnumber) permitx.x.x.x x.x.x.x(网段及掩码)或:
(config)#ip prefix-list xxx(prefixlistname/number)permit x.x.x.x/x(网段及网段位数)
(config)#route-map xxx(routemapname) permitxxx(number)
(config-route-map)#match ip addressxxx(accesslistnumber)或:
(config-route-map)#match ip addressprefix-listxxx(prefixlistname/number)
(config-route-map)#set orgin egp xxx(as-number) //设置起源区号
(config)#router bgp xxx
(config-router)#neighbor x.x.x.x route-mapxxx(routemapname) out
//为去往邻居的出去方向的路由设置策略
#show ip bgp
BGP之as-path属性
(4)配置bgp的origin属性
(config)# ip prefix-list xxx(prefixlistname/number)permit x.x.x.x/x(网段及网段位数)
(config)#route-map xxx(routemapname) permitxxx(number)
(config-route-map)#match ip address prefix-listxxx(prefixlistname/number)
(config-route-map)#set as-path prepend x x x ...(可配一连串的区域路径) //为匹配的路由追加AS
(config)#router bgp xxx
(config-router)#neighbor x.x.x.x route-map xxx(routemapname)out
#show ip bgp
BGP在路由判定时,AS-PATH属性优先于ORIGIN属性!!!
xxxxxxxxxxxxxxxx更多内容还再进一步编写,敬请期待xxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx
由于小菜目前能力有限,以上内容可能有所错漏,还望各大神能多多赐教、指点迷津,感谢!!!
下一代互联网技术(路由配置)