首页 > 代码库 > HDUJ 1789 Doing Homework again 贪心

HDUJ 1789 Doing Homework again 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6335    Accepted Submission(s): 3746


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
0 3 5


#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;

struct node
{
	int time,score;
}s[1005];
int v[1005];

int cmp(node x,node y)
{
	if(x.score==y.score)
		return x.time<y.time;
	else
		return x.score>y.score;
}

int main()
{
	int n,m;
	cin>>n;
	while(n--)
	{
		cin>>m;
		int i,j;
		for(i=0;i<m;i++)
			cin>>s[i].time;
		for(j=0;j<m;j++)
			cin>>s[j].score;

		sort(s,s+m,cmp);
		int sum=0;
		memset(v,0,sizeof(v));
		for(i=0;i<m;i++)
		{
			int t=s[i].time;
			if(v[t]==0)
				v[t]=1;
			else
			{
				while(v[t]==1)  t--;
				if(t==0)   sum += s[i].score;
				else   v[t]=1;
			}
		}

		cout<<sum<<endl;
	}

	return 0;
}


HDUJ 1789 Doing Homework again 贪心