首页 > 代码库 > 杭电 1518 Square (深搜)(回溯)

杭电 1518 Square (深搜)(回溯)

http://acm.hdu.edu.cn/showproblem.php?pid=1518

Square

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8343    Accepted Submission(s): 2706

Problem Description
Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?
 
Input
The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.
 
Output
For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".
 

Sample Input
3 4 1 1 1 1 5 10 20 30 40 50 8 1 7 2 6 4 4 3 5
 

Sample Output
yes no yes
 

AC代码:
#include<iostream>  
#include<cstring>  
using namespace std;  

int v[23],n,flag;  
int a[23],sum;  

void dfs(int p,int ans,int t)  
{  
	if(ans==sum/4)  
	{  
		p++;  
	//	cout<<p<<"-------\n";
		if(p==4)  
		{  
			flag=1;  
			return ;  
		}  
		else ans=0;  
		t=0;  
	}  
	
	if(flag)   return ;  
	for(int i=t;i<n;i++)  
		if(!v[i] && a[i]+ans<=sum/4)  
		{  
			v[i]=1;  
		//	cout<<ans+a[i]<<"   ";
			dfs(p,ans+a[i],i);  
			v[i]=0;  
		}  
}  

int main()  
{  
	int T;  
	cin>>T;  
	while(T--)  
	{  
		cin>>n;  
		int max;  
		max=sum=0;  
		for(int i=0;i<n;i++)  
		{  
			cin>>a[i];  
			sum += a[i];  
			if(max<a[i])   max=a[i];  
		}  
		
		if(sum%4!=0 || max>sum/4)  
			cout<<"no\n";  
		else  
		{  
			memset(v,0,sizeof(v));  
			flag=0;  
			dfs(0,0,0);  
			if(flag)   cout<<"yes\n";  
			else     cout<<"no\n";  
		}  
	}  
	
	return 0;  
}