首页 > 代码库 > hdu 1297 Children’s Queue

hdu 1297 Children’s Queue

Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10540    Accepted Submission(s): 3390


Problem Description
There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side. The case n=4 (n is the number of children) is like
FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM
Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?
 

Input
There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)
 

Output
For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.
 

Sample Input
1 2 3
 

Sample Output
1 2 4
 

递推+大数:
分男女生考虑,设共有n个人。       //f(n)表示当有n个人的时候合法序列的个数,ak表示第k个人
1.当a1为男生时,有f(n-1)种可能。
2.当a1是女生时,a2必为女生.
  1)当a1、a2都为女生时,a3为男生,有f(n-3)种可能。
  2)当a1、a2、a3都为女生,a4为男生时,有f(n-4)种可能。
  ......  
  以此类推     // 下式中f(1)表示n全为女生时那种情况,规定f(0) = 1。

故有 f(n) = f(n-1) + f(n-3) + f(n-4) + f(n-5) + f(n-6) + ... + f(1) + f(0) + 1; //(1)式
又 f(n-2) =          f(n-3) +          f(n-5) + f(n-6) + ... + f(1) + f(0) + 1; //(2)式
由以上两式((1)式-(2)式)得 f(n) = f(n-1) + f(n-2) + f(n-4)




import java.math.BigInteger;
import java.util.Scanner;
public class pp {
	public static void main(String[] args) 
	{
		Scanner cin=new Scanner(System.in);
		BigInteger a[]=new BigInteger[1001];
		a[0]=BigInteger.valueOf(1);
		a[1]=BigInteger.valueOf(1);
		a[2]=BigInteger.valueOf(2);
	    a[3]=BigInteger.valueOf(4);
		  for(int i=4;i<=1000;i++)
			//a[i]=(a[i-1].multiply(BigInteger.valueOf(2))).subtract(a[i-3]);
			  a[i]=(a[i-1].add(a[i-2])).add(a[i-4]);
		while(cin.hasNext())
		{
	      int n=cin.nextInt();
		  System.out.println(a[n]);
		}
	}	
}