首页 > 代码库 > hdu 4891 The Great Pan

hdu 4891 The Great Pan

The Great Pan

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 529    Accepted Submission(s): 200


Problem Description
As a programming contest addict, Waybl is always happy to take part in various competitive programming contests. One day, he was competing at a regional contest of Inventing Crappy Problems Contest(ICPC). He tried really hard to solve a "geometry" task without success.

After the contest, he found that the problem statement is ambiguous! He immediately complained to jury. But problem setter, the Great Pan, told him "There are only four possibilities, why don‘t you just try all of them and get Accepted?".

Waybl was really shocked. It is the first time he learned that enumerating problem statement is as useful as trying to solve some ternary search problem by enumerating a subset of possible angle!

Three years later, while chatting with Ceybl, Waybl was told that some problem "setters" (yeah, other than the Great Pan) could even change the whole problem 30 minutes before the contest end! He was again shocked.

Now, for a given problem statement, Waybl wants to know how many ways there are to understand it.

A problem statement contains only newlines and printable ASCII characters (32 ≤ their ASCII code ≤ 127) except ‘{‘, ‘}‘, ‘|‘ and ‘$‘.

Waybl has already marked all ambiguity in the following two formats:

1.{A|B|C|D|...} indicates this part could be understand as A or B or C or D or ....
2.$blah blah$ indicates this part is printed in proportional fonts, it is impossible to determine how many space characters there are.

Note that A, B, C, D won‘t be duplicate, but could be empty. (indicate evil problem setters addedclarified it later.)

Also note that N consecutive spaces lead to N+1 different ways of understanding, not 2N ways.

It is impossible to escape from "$$" and "{}" markups even with newlines. There won‘t be nested markups, i.e. something like "${A|B}$" or "{$A$|B}" or "{{A|B}|C}" is prohibited. All markups will be properly matched.
 

Input
Input contains several test cases, please process till EOF.
For each test case, the first line contains an integer n, indicating the line count of this statement. Next n lines is the problem statement.
1 ≤ n ≤ 1000, size of the input file will not exceed 1024KB.
 

Output
For each test case print the number of ways to understand this statement, or "doge" if your answer is more than 105.
 

Sample Input
9 I‘ll shoot the magic arrow several times on the ground, and of course the arrow will leave some holes on the ground. When you connect three holes with three line segments, you may get a triangle. {|It is hole! Common sense!| No Response, Read Problem Statement|don‘t you know what a triangle is?} 1 Case $1: = >$ 5 $/*This is my code printed in proportional font, isn‘t it cool?*/ printf("Definitely it is cooooooool %d\n",4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4);$ 2 $Two space$ and {blue| red} color!
 

Sample Output
4 4 doge 6
 


题解及代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#define maxn 1024*1024+20
using namespace std;
char s[maxn],t[maxn];

int main()
{
    int n;
    memset(t,0,sizeof(t));
    while(scanf("%d",&n)!=EOF)
    {
        getchar();
        memset(s,'\0',sizeof(s));
        for(int i=0;i<n;i++)
        {
            gets(t);
            strcat(s,t);
        }
        //cout<<s<<endl;
        int len=strlen(s);

        __int64 ans=1;
        for(int i=0;i<len;i++)
        {
            if(s[i]=='$')
            {
                int k=0;
                for(i+=1;;i++)
                {
                    if(s[i]=='$')
                    {
                        ans*=(k+1);
                        break;
                    }
                    else if(s[i]==' ') k++;
                    else
                    {
                        ans*=(k+1);
                        if(ans>100000) ans=100001; //没写这句,WA了n次
                        k=0;
                    }
                }

            }
            if(ans>100000) break;

            if(s[i]=='{')
            {
                int k=0;
                for(i+=1;;i++)
                {
                    if(s[i]=='}')
                    {
                        ans*=(k+1);
                        break;
                    }
                    else if(s[i]=='|') k++;
                }
            }
            if(ans>100000) break;
        }

        if(ans>100000) printf("doge\n");
        else printf("%I64d\n",ans);
    }
    return 0;
}
/*
一道签到体,被自己WA了N次,都已经在怀疑是不是读错题目了,结果是爆精度WA,还是小看了数据啊。

题目分两种情况:1.{} 求出括号中间|的个数为k,ans*=k+1;
                2.$$ q求出$$中间连续空格的个数,对于每个连续的空格,ans*=ki;
                
如果ans>100000,输出doge,否则输出ans。

本人WA是因为在计算$$过程中,可能会爆精度,没有考虑到这一点,提示点在代码中已经注明。
*/