首页 > 代码库 > UVA 465-- Overflow (atof 函数)

UVA 465-- Overflow (atof 函数)

 Overflow 

Write a program that reads an expression consisting of two non-negative integer and an operator. Determine if either integer or the result of the expression is too large to be represented as a ``normal‘‘ signed integer (type integer if you are working Pascal, type int if you are working in C).

Input

An unspecified number of lines. Each line will contain an integer, one of the two operators + or *, and another integer.

Output

For each line of input, print the input followed by 0-3 lines containing as many of these three messages as are appropriate: ``first number too big‘‘, ``second number too big‘‘, ``result too big‘‘.

Sample Input

300 + 3
9999999999999999999999 + 11

Sample Output

300 + 3
9999999999999999999999 + 11
first number too big
result too big
本来是道模拟题,wa了7次没过去 无奈直接上atof函数了 ,此函数将输入的字符串转化为浮点型(double)
#include<cstdio>
#include <cstdlib>
#include <iostream>
#include <cstring>
using namespace std;
const int MAX=2147483647;
int main()
{
	char op,a[1100],b[1100];
	while(cin>>a>>op>>b)
	{
		cout<<a<<" "<<op<<" "<<b<<endl;
		double x=atof(a),y=atof(b);
		if(x>MAX)
			cout<<"first number too big"<<endl;
		if(y>MAX)
			cout<<"second number too big"<<endl;
		if(op=='+')
		{
			double ans=x+y;
			if(ans>MAX)
				cout<<"result too big"<<endl;
		}
		if(op=='*')
		{
			double ans=x*y;
			if(ans>MAX)
				cout<<"result too big"<<endl;
		}

	}
	return 0;
}