首页 > 代码库 > Choose the best route

Choose the best route

Problem Description
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer 1,2,3…n.
 

Input
There are several test cases. Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n="" stands="" for="" the="" number="" of="" bus="" stations="" in="" this="" city="" and="" m="" directed="" ways="" between="" .(maybe="" there="" are="" several="" two="" .)="" s="" station="" that="" near="" kiki’s="" friend’s="" home.="" then="" follow="" lines="" ,each="" line="" contains="" three="" integers="" p="" ,="" q="" t="" (0<t<="1000)." means="" from="" to="" is="" a="" way="" it="" will="" costs="" minutes="" .="" with="" an="" integer="" w(0<w<n),="" kiki="" can="" take="" at="" beginning.="" follows="" w="" these="" stations.="" <="" div="">
 

Output
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

Sample Input
5 8 5 1 2 2 1 5 3 1 3 4 2 4 7 2 5 6 2 3 5 3 5 1 4 5 1 2 2 3 4 3 4 1 2 3 1 3 4 2 3 2 1 1
 

Sample Output
1 -1
 

Author
dandelion
 


#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#define MX 1000000
using namespace std;
int t;
int m[1005][1005],D[1000],S[1000];
int p[1005],num[10005];
int dstl()
{
    memset(p,0,sizeof(p));
    for(int i=1;i<=t;i++)num[i]=MX;
    for(int i=1;i<=t;i++)
    {
        num[i]=m[0][i];
    }
    for(int i=1;i<=t;i++)
    {
        int k=0,mi=MX;
        for(int j=1;j<=t;j++)
        {
            if(!p[j]&&num[j]<mi)
            {
                mi=num[j];
                k=j;
            }
        }
        p[k]=1;
        if(mi==MX)return MX;
        for(int j=1;j<=t;j++)
        {
            if(!p[j]&&num[j]>num[k]+m[k][j])
                  num[j]=num[k]+m[k][j];
        }
    }
}
int main()
{
   int s,d,sb,ch;
   int a,b,time;
   while(scanf("%d%d%d",&t,&s,&d)!=EOF)
   {
        for(int i=0;i<=t;i++)
           for(int j=0;j<=t;j++)
              m[i][j]=MX;
        for(int i=1;i<=s;i++)
        {
            scanf("%d%d%d",&a,&b,&time);
            if(time<m[a][b])
                m[a][b]=time;
        }
        scanf("%d",&sb);
        for(int i=0;i<sb;i++)
        {
            scanf("%d",&ch);
            m[0][ch]=0;
        }
        dstl();
        if(num[d]==MX)
           printf("-1\n");
        else
           printf("%d\n",num[d]);
   }
  return 0;
}