首页 > 代码库 > POJ3077 Rounders

POJ3077 Rounders

Rounders
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7605 Accepted: 4931

Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line. 

Note: Round up on fives.

Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output

20
10
4
5
100
10000000
50000000
2000
500

Source

South Central USA 2006

#include <stdio.h>
#include <string.h>
char str[20];

int main()
{
    int t, n, a, b, len, i, jin;
    scanf("%d", &t);
    while(t--){
        scanf("%s", str);
        len = strlen(str);
        while(len > 1){
            --len;
            if(str[len] >= '5'){
                str[len] = '0'; ++str[len-1];
            }else str[len] = '0';
        }
        jin = 0;
        if(str[0] > '9') jin = 1, str[0] = '0';
        if(jin) putchar('1');
        puts(str);
    }
    return 0;
}