首页 > 代码库 > UVA 657-The die is cast(双重BFS)

UVA 657-The die is cast(双重BFS)


InterGames is a high-tech startup company that specializes in developing technology that allows users to play games over the Internet. A market analysis has alerted them to the fact that games of chance are pretty popular among their potential customers. Be it Monopoly, ludo or backgammon, most of these games involve throwing dice at some stage of the game.

Of course, it would be unreasonable if players were allowed to throw their dice and then enter the result into the computer, since cheating would be way to easy. So, instead, InterGames has decided to supply their users with a camera that takes a picture of the thrown dice, analyzes the picture and then transmits the outcome of the throw automatically.

For this they desperately need a program that, given an image containing several dice, determines the numbers of dots on the dice.

We make the following assumptions about the input images. The images contain only three dif- ferent pixel values: for the background, the dice and the dots on the dice. We consider two pixelsconnected if they share an edge - meeting at a corner is not enough. In the figure, pixels A and B are connected, but B and C are not.

A set S of pixels is connected if for every pair (a,b) of pixels in S, there is a sequence$a_1, a_2, \dots, a_k$ in S such that a = a1 and b = ak , and ai and ai+1 are connected for $1 \le i < k$.

We consider all maximally connected sets consisting solely of non-background pixels to be dice. `Maximally connected‘ means that you cannot add any other non-background pixels to the set without making it dis-connected. Likewise we consider every maximal connected set of dot pixels to form a dot.

Input 

The input consists of pictures of several dice throws. Each picture description starts with a line containing two numbers w and h, the width and height of the picture, respectively. These values satisfy $5 \le?w,h \le 50$.

The following h lines contain w characters each. The characters can be: ``.‘‘ for a background pixel, ``*‘‘ for a pixel of a die, and ``X‘‘ for a pixel of a die‘s dot.

Dice may have different sizes and not be entirely square due to optical distortion. The picture will contain at least one die, and the numbers of dots per die is between 1 and 6, inclusive.

The input is terminated by a picture starting with w = h = 0, which should not be processed.

Output 

For each throw of dice, first output its number. Then output the number of dots on the dice in the picture, sorted in increasing order.

Print a blank line after each test case.

Sample Input 

30 15
..............................
..............................
...............*..............
...*****......****............
...*X***.....**X***...........
...*****....***X**............
...***X*.....****.............
...*****.......*..............
..............................
........***........******.....
.......**X****.....*X**X*.....
......*******......******.....
.....****X**.......*X**X*.....
........***........******.....
..............................
0 0

Sample Output 

Throw 1
1 2 2 4
终于体会到不会DFS的痛苦了,这题敲的BFSwa了6次才过,说一下思路,外面for循环遍历矩阵,遇到*就去BFS搜*(把搜到的*置为。),搜到X就继续另外BFS搜X(把搜到的X置为*)

注意特殊数据如 xxxx 答案为0

#include <iostream>
#include <cstdio>
#include <cstring>
#include <vector>
#include <queue>
#include <algorithm>
using namespace std;
typedef struct node
{
	int x,y;
	node (int a,int b){x=a;y=b;}
};
int dir[4][2] = {{0, 1}, {0, -1}, {1, 0}, { -1, 0}};
char ma[60][60];
int cnt,m, n, ans[1000];
void bfs2(int x, int y)
{
  ma[x][y]='*';
  queue <node> S;
  S.push(node(x,y));
  while(!S.empty())
  {
  	node v=S.front();S.pop();
	for (int i = 0; i < 4; i++)
		{
			int tx = v.x + dir[i][0];
			int ty = v.y + dir[i][1];

			if (tx>=0&&tx<m&&ty>=0&&ty<n&&ma[tx][ty]=='X')
			{
				ma[tx][ty]='*';
				S.push(node(tx,ty));
			}
		}
  }
}
void bfs1(int x, int y)
{
	queue <node> Q;
	ma[x][y]='.';
	Q.push(node(x, y));

	while (!Q.empty())
	{
		node v = Q.front();Q.pop();
		if (ma[v.x][v.y] == 'X')
		{
			bfs2(v.x, v.y);
			ans[cnt]++;
		}
		else if(ma[v.x][v.y]=='*')
		{
			ma[v.x][v.y]='.';
		}
		for (int i = 0; i < 4; i++)

		{
			int tx = v.x + dir[i][0];
			int ty = v.y + dir[i][1];

			if (ma[tx][ty]!='.'&&tx>=0&&tx<m&&ty>=0&&ty<n)
			{
			if (ma[tx][ty] == 'X')
		    {
			bfs2(tx, ty);
			ans[cnt]++;
		    }
		    else if(ma[tx][ty]=='*')
		    {
		 	ma[tx][ty]='.';
		    }
			Q.push(node(tx,ty));
			}
		}
	}
	cnt++;
}
int main()
{
	int T=1,i;
	while (cin >> n >> m)
	{
		if (!m && !n)
		{
			break;
		}
		cnt=0;
		getchar();
		memset(ans, 0, sizeof(ans));
		memset(ma,'.',sizeof(ma));
		for (i = 0; i < m; i++)
		{
			cin >> ma[i];
		}
		for (i = 0; i < m; i++)
			for (int j = 0; j < n; j++)
				if (ma[i][j]=='*')
				{
					bfs1(i, j);
				}
		sort(ans,ans+cnt);
		cout<<"Throw "<<T++<<endl;
		for(i=0;i<cnt-1;i++)
			cout<<ans[i]<<" ";
		cout<<ans[i]<<endl;
		cout<<endl;
	}
	return 0;
}