首页 > 代码库 > HDU 1251 统计难题(字典树)

HDU 1251 统计难题(字典树)

Problem Description
Ignatius最近遇到一个难题,老师交给他很多单词(只有小写字母组成,不会有重复的单词出现),现在老师要他统计出以某个字符串为前缀的单词数量(单词本身也是自己的前缀).
 

Input
输入数据的第一部分是一张单词表,每行一个单词,单词的长度不超过10,它们代表的是老师交给Ignatius统计的单词,一个空行代表单词表的结束.第二部分是一连串的提问,每行一个提问,每个提问都是一个字符串.

注意:本题只有一组测试数据,处理到文件结束.
 

Output
对于每个提问,给出以该字符串为前缀的单词的数量.
 

Sample Input
banana band bee absolute acm ba b band abc
 

Sample Output
2 3 1 0
 
第一棵字典树,比别人足足晚了二个月。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<limits.h>
typedef long long LL;
using namespace std;
typedef struct Trie{
    int num;
    Trie *next[26];
}Trie;
Trie root;
void buildtrie(char *str)//构造字典树
{
    int len=strlen(str);
    Trie *p=&root,*q;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'a';
        if(p->next[id]==NULL)//若子节点不存在,则构造
        {
            q=(Trie *)malloc(sizeof(root));
            q->num=1;
            for(int j=0;j<26;j++)
               q->next[j]=NULL;
            p->next[id]=q;
            p=p->next[id];
        }
        else//若存在则遍历
        {
            p->next[id]->num++;
            p=p->next[id];
        }
    }
}
int find(char *str)//查找
{
    int len=strlen(str);
    Trie *p=&root;
    for(int i=0;i<len;i++)
    {
        int id=str[i]-'a';
        p=p->next[id];
        if(p==NULL)
            return 0;
    }
    return p->num;
}
int main()
{
    char str[15];
    for(int i=0;i<26;i++)
        root.next[i]=NULL;
    while(gets(str)&&str[0]!='\0')
        buildtrie(str);
    memset(str,0,sizeof(str));
    while(~scanf("%s",str))
    {
        int ans=find(str);
        printf("%d\n",ans);
    }
    return 0;
}


HDU 1251 统计难题(字典树)