首页 > 代码库 > HDU1019 最小公倍数

HDU1019 最小公倍数

Least Common Multiple

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 30295 Accepted Submission(s): 11460


Problem Description
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input
2 3 5 7 15 6 4 10296 936 1287 792 1

Sample Output
105 10296
我以为这个题是有什么算法呢,因为我看的都是关于两个数求最小公倍数的,但这个是多个数,所以一开始没敢写,后来才想到有这种穷举方式试一下,没想到能过啊
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;

int main()
{
	int t,s,n,i,j,m,a[5000];
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		sort(a,a+n);
		for(i=a[n-1];;i+=a[n-1])
		{
			for(j=0;j<n-1;j++)
				if(i%a[j]!=0)
					break;
			if(j==n-1)
				break;
		}
		printf("%d\n",i);
	}
	return 0;
}