首页 > 代码库 > Prime Cuts(poj1595)

Prime Cuts(poj1595)

/*Prime Cuts
Description

A prime number is a counting number (1, 2, 3, ...) that is evenly divisible only by 1 and itself. In this problem you are to write a program that will cut some number of prime numbers from the list of prime numbers between (and including) 1 and N. Your program will read in a number N; determine the list of prime numbers between 1 and N; and print the C*2 prime numbers from the center of the list if there are an even number of prime numbers or (C*2)-1 prime numbers from the center of the list if there are an odd number of prime numbers in the list.
Input

Each input set will be on a line by itself and will consist of 2 numbers. The first number (1 <= N <= 1000) is the maximum number in the complete list of prime numbers between 1 and N. The second number (1 <= C <= N) defines the C*2 prime numbers to be printed from the center of the list if the length of the list is even; or the (C*2)-1 numbers to be printed from the center of the list if the length of the list is odd.
Output

For each input set, you should print the number N beginning in column 1 followed by a space, then by the number C, then by a colon (:), and then by the center numbers from the list of prime numbers as defined above. If the size of the center list exceeds the limits of the list of prime numbers between 1 and N, the list of prime numbers between 1 and N (inclusive) should be printed. Each number from the center of the list should be preceded by exactly one blank. Each line of output should be followed by a blank line. Hence, your output should follow the exact format shown in the sample output.
Sample Input

21 2
18 2
18 18
100 7
Sample Output

21 2: 5 7 11

18 2: 3 5 7 11

18 18: 1 2 3 5 7 11 13 17

100 7: 13 17 19 23 29 31 37 41 43 47 53 59 61 67


*/
/*思路就是 用打表法,打出从1-1000之间所有的素数,输入m,n,统计1-m之间素数的个数sum,如果是奇数,找出素数序列sum/2+1,输出 从第sum/2+1-n到sum/2+1+n之间的素数, 如果sum是偶数,找出中间的两个素数序号p1,p2.输出从p1-n到p2+n之间所有的素数;如果sum<n*2,输出从1-m之间所有的素数*/
 /*注意格式:每输出一组结果中间空一行*/
#include<stdio.h>
int main()
{
    int a[1001]={1,0};
    int b[1001];
    int i,j,k=1;
    for(i=2;i<=1000;i++)
    {
        if(!a[i])
        for(j=i+i;j<=1000;j+=i)
        {
            a[j]=1;
        }
    }
    for(i=1;i<=1000;i++)
    {
        if(!a[i])
        {
            b[k++]=i;
        }
    }
    int m,n;
    while(scanf("%d %d",&m,&n)!=EOF)
    {
        int k=0,sum=0,t;
        for(i=1;i<=m;i++)
        {
            k+=a[i];
        }
        sum=m-k;
        printf("%d %d:",m,n);
        if(sum<n*2)
        {
           
            for(i=1;i<=sum;i++)
            {
                printf(" %d",b[i]);
            }
            printf("\n\n");
        }
        else
        {
            for(i=(sum+1)/2-n+1;i<=sum/2+n;i++)
            {
                printf(" %d",b[i]);
            }
            printf("\n\n");
        }
    }
    return 0;
}