首页 > 代码库 > Big Event in HDU(背包九讲_多重背包转01背包)

Big Event in HDU(背包九讲_多重背包转01背包)


Big Event in HDUCrawling in process...Crawling failedTime Limit:5000MS    Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

SubmitStatus

Description

Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don‘t know that Computer College had ever been split into Computer College and Software College in 2002.
The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is N (0<N<1000) kinds of facilities (different value, different kinds).
 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding number of the facilities) each. You can assume that all V are different.
A test case starting with a negative integer terminates input and this test case is not to be processed.
 

Output

For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that A is not less than B.
 

Sample Input

2 10 1 20 1 3 10 1 20 2 30 1 -1
 

Sample Output

20 10 40 40
题意:有n种物品,然后每一行的两个数,第一个是价值,第二个是商品的数量,把这n种物品分为A,B两份,要求A,B之间的差值大于等于0,且A>=B
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
int dp[100010];
int main()
{
	int p[1010],num[1010];
	int n,i,j,k;
	int sum=0,ave;
	while(~scanf("%d",&n))
	{
	    if(n<=-1)//这里注意
            break;
        sum=0;
		for(i=1;i<=n;i++)
		{
			scanf("%d %d",&p[i],&num[i]);
			sum+=p[i]*num[i];
		}
        memset(dp,0,sizeof(dp));
		ave=sum/2;
		for(i=1;i<=n;i++)
			for(j=1;j<=num[i];j++)
				for(k=ave;k>=p[i];k--)
					dp[k]=max(dp[k],dp[k-p[i]]+p[i]);
		printf("%d %d\n",sum-dp[sum/2],dp[sum/2]);
	}
	return 0;
}




Big Event in HDU(背包九讲_多重背包转01背包)