有限小数化为最简分数
2024-09-05 06:16:45 218人阅读
/*
请将有限小数化为最简分数。
Input
一个整数n 表示需要转化的小数个数; 接下来n行,每行有一个有限小数。(保证小数位数不超过9位)
Output
输出有n行,每行为小数对应的最简分数
Sample Input
2
0.5
0.4
Sample Output
1/2 2/5
注意精度问题,数据保证不会有类似1.0的小数。
*/
#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
int Gcd(int a,int b){
if(a<b){
int t;
t = a;
a = b;
b = t;
}
return b!=0?Gcd(b,a%b):a;
}
char str[50],str2[50];
int main()
{
int t,i,k,count,big,small,mul1,mul2,gcd,sum;
cin>>t;
while(t--)
{
cin>>str;
count = 0;
int len = strlen (str);
for(i=0; i< len;i++){
if(str[i]!=‘.‘){
count++;
}
else{
break;
}
}
mul1 = mul2 = 1;
sum = big = small = 0;
for(i=0; i<count; i++){
有限小数化为最简分数
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉:
投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。