首页 > 代码库 > HDU4027Can you answer these queries?(线段树区间和,坑)

HDU4027Can you answer these queries?(线段树区间和,坑)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 8674 Accepted Submission(s): 1971


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.

Input
The input contains several test cases, terminated by EOF.
For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 263.
The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.

Sample Input
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8

Sample Output
Case #1: 19 7 6

Source
The 36th ACM/ICPC Asia Regional Shanghai Site —— Online Contest 
0:区间每个数开平方根取整。
1:区间和
#include<stdio.h>
#include<math.h>
#define N 100100
struct nn
{
    int flag;//为0,说明这个区间内的数全为1
    __int64 sum;//区间和
}tree[N*3];
void builde(int l,int r,int k)
{
    int m=(l+r)/2;
    if(l==r)
    {
        scanf("%I64d",&tree[k].sum);
      tree[k].flag=1;if(tree[k].sum<=1)tree[k].flag=0; return ;
    }
    builde(l,m,k*2);
    builde(m+1,r,k*2+1);
    tree[k].sum=tree[k*2].sum+tree[k*2+1].sum;
    tree[k].flag=tree[k*2].flag|tree[k*2+1].flag;
}
void updata(int l,int r,int k,int L,int R)
{
    int m=(r+l)/2;
    if(l==r)
    {
        tree[k].sum=(__int64)sqrt(1.0*tree[k].sum);
        if(tree[k].sum<=1)tree[k].flag=0; return ;
    }
    if(L<=m&&tree[k*2].flag)updata(l,m,k*2,L,R);
    if(R>m&&tree[k*2+1].flag)updata(m+1,r,k*2+1,L,R);
    tree[k].sum=tree[k*2].sum+tree[k*2+1].sum;
    tree[k].flag=tree[k*2].flag|tree[k*2+1].flag;
}
__int64 query(int l,int r,int k,int L,int R)
{
    int m=(l+r)/2;
    if(L<=l&&r<=R)
    {
        return tree[k].sum;
    }
    __int64 sum=0;
    if(L<=m)sum+=query(l,m,k*2,L,R);
    if(R>m)sum+=query(m+1,r,k*2+1,L,R);
    return sum;
}
int main()
{
    int n,m,t=0,o,L,R;
    while(scanf("%d",&n)>0)
    {
        builde(1,n,1);
        scanf("%d",&m);
        printf("Case #%d:\n",++t);
        while(m--)
        {
            scanf("%d%d%d",&o,&L,&R);
            int tem;
            if(L>R){tem=L;L=R;R=tem;}//注意了
            if(o==0)updata(1,n,1,L,R);
            else
                printf("%I64d\n",query(1,n,1,L,R));
        }
        printf("\n");
    }
    return 0;
}


HDU4027Can you answer these queries?(线段树区间和,坑)