首页 > 代码库 > HDOJ 2027 统计元音

HDOJ 2027 统计元音

统计元音

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 37878    Accepted Submission(s): 15559



Problem Description
统计每个元音字母在字符串中出现的次数。
 

Input
输入数据首先包括一个整数n,表示测试实例的个数,然后是n行长度不超过100的字符串。
 

Output
对于每个测试实例输出5行,格式如下:
a:num1
e:num2
i:num3
o:num4
u:num5
多个测试实例之间由一个空行隔开。

请特别注意:最后一块输出后面没有空行:)
 

Sample Input
2 aeiou my name is ignatius
 

Sample Output
a:1 e:1 i:1 o:1 u:1 a:2 e:1 i:3 o:0 u:1
 

Author
lcy
 

Source
C语言程序设计练习(四)
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2031 2032 2030 2028 2029 
 



依然水题呃,,注意PE问题。

#include <iostream>
using namespace std;
int main(){
	int n;
	char a[105];
	cin >> n;
	getchar();
	while (n--){
		gets(a);
		int b[5] = { 0 };
		for (int i = 0; i < strlen(a); i++){
			if (a[i] == 'a')
				b[0]++;
			else if (a[i] == 'e')
				b[1]++;
			else if (a[i] == 'i')
				b[2]++;
			else if (a[i] == 'o')
				b[3]++;
			else if (a[i] == 'u')
				b[4]++;
		}

		cout << "a:" << b[0] << endl;
		cout << "e:" << b[1] << endl;
		cout << "i:" << b[2] << endl;
		cout << "o:" << b[3] << endl;
		cout << "u:" << b[4] << endl;
		if (n!=0)
		cout << endl;
	}
	cin >> a;
	return 0;
}


HDOJ 2027 统计元音