首页 > 代码库 > poj 1458 Common Subsequence

poj 1458 Common Subsequence

Common Subsequence
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39058 Accepted: 15739

Description

A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = < x1, x2, ..., xm > another sequence Z = < z1, z2, ..., zk > is a subsequence of X if there exists a strictly increasing sequence < i1, i2, ..., ik > of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = < a, b, f, c > is a subsequence of X = < a, b, c, f, b, c > with index sequence < 1, 2, 4, 6 >. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.

Input

The program input is from the std input. Each data set in the input contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct.

Output

For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.

Sample Input

abcfbc         abfcab
programming    contest 
abcd           mnp

Sample Output

4
2
0

题意:求最长公共子序列;

解题思路:

求最长公共子序列(LCS):

字符串:s:  S1S2S3S4.......Si,t:   T1T2T3T4..........Tj;

定义一个数组dp[i][j]表示S1S2S3S4.......Si和T1T2T3T4..........Tj所对应的最长公共子序列;

则S1S2S3S4.......Si+1和T1T2T3T4..........Tj+1所对应的最长公共子序列可能为:

(1)如果Si+1==Tj+1,则S1S2S3S4.......Si和T1T2T3T4..........Tj所对应的最长公共子序列+1;

(2)S1S2S3S4.......Si+1和T1T2T3T4..........Tj所对应的最长公共子序列;

(3)S1S2S3S4.......Si和T1T2T3T4..........Tj+1所对应的最长公共子序列;

所以dp的状态转移方程为dp[i][j]=max( dp[i-1][j-1] + (a[i]==b[j]) , max( dp[i-1][j] , dp[i][j-1] ) )

#include <iostream>
#include <string.h>
using namespace std;
char a[1000],b[1000];
int dp[1000][1000];
int max(int a,int b){
	return a>b?a:b;
}
int LCS(char *a,char *b){
	int n=strlen(a),m=strlen(b);
	for (int i=0;i<n;i++)
		dp[i][0]=0;
	for (int j=0;j<m;j++)
		dp[0][j]=0;
	for (int i=0;i<n;i++)
		for (int j=0;j<m;j++){
			if (a[i]==b[j])
				dp[i+1][j+1]=dp[i][j]+1;
			else
				dp[i+1][j+1]=max(dp[i][j+1],dp[i+1][j]);
		}
	return dp[n][m];
}
int main(){
	while (cin>>a>>b){
		cout<<LCS(a,b)<<endl;
	}
	return 0;
} 


poj 1458 Common Subsequence