首页 > 代码库 > STL 全排列
STL 全排列
The Little Girl who Picks Mushrooms
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 1805 Accepted Submission(s): 579
Problem Description
It‘s yet another festival season in Gensokyo. Little girl Alice planned to pick mushrooms in five mountains. She brought five bags with her and used different bags to collect mushrooms from different mountains. Each bag has a capacity of 2012 grams. Alice has finished picking mushrooms in 0 ≤ n ≤ 5 mountains. In the i-th mountain, she picked 0 ≤ wi ≤ 2012 grams of mushrooms. Now she is moving forward to the remained mountains. After finishing picking mushrooms in all the five mountains, she want to bring as much mushrooms as possible home to cook a delicious soup.
Alice lives in the forest of magic. At the entry of the forest of magic, live three mischievous fairies, Sunny, Lunar and Star. On Alice‘s way back home, to enter the forest, she must give them exactly three bags of mushrooms whose total weight must be of integral kilograms. If she cannot do so, she must leave all the five bags and enter the forest with no mushrooms.
Somewhere in the forest of magic near Alice‘s house, lives a magician, Marisa. Marisa will steal 1 kilogram of mushrooms repeatedly from Alice until she has no more than 1 kilogram mushrooms in total. So when Alice gets home, what‘s the maximum possible amount of mushrooms Alice has? Remember that our common sense doesn‘t always hold in Gensokyo. People in Gensokyo believe that 1 kilogram is equal to 1024 grams.
Alice lives in the forest of magic. At the entry of the forest of magic, live three mischievous fairies, Sunny, Lunar and Star. On Alice‘s way back home, to enter the forest, she must give them exactly three bags of mushrooms whose total weight must be of integral kilograms. If she cannot do so, she must leave all the five bags and enter the forest with no mushrooms.
Somewhere in the forest of magic near Alice‘s house, lives a magician, Marisa. Marisa will steal 1 kilogram of mushrooms repeatedly from Alice until she has no more than 1 kilogram mushrooms in total. So when Alice gets home, what‘s the maximum possible amount of mushrooms Alice has? Remember that our common sense doesn‘t always hold in Gensokyo. People in Gensokyo believe that 1 kilogram is equal to 1024 grams.
Input
There are about 8192 test cases. Proceed to the end of file.
The first line of each test case contains an integer 0 ≤ n ≤ 5, the number of mountains where Alice has picked mushrooms. The second line contains n integers 0 ≤ wi ≤ 2012, the amount of mushrooms picked in each mountain.
The first line of each test case contains an integer 0 ≤ n ≤ 5, the number of mountains where Alice has picked mushrooms. The second line contains n integers 0 ≤ wi ≤ 2012, the amount of mushrooms picked in each mountain.
Output
For each test case, output the maximum possible amount of mushrooms Alice can bring home, modulo 20121014 (this is NOT a prime).
Sample Input
1 9 4 512 512 512 512 5 100 200 300 400 500 5 208 308 508 708 1108
Sample Output
1024 1024 0 792HintIn the second sample, if Alice doesn‘t pick any mushrooms from the 5-th mountain. She can give (512+512+0) =1024 grams of mushrooms to Sunny, Lunar and Star. Marisa won‘t steal any mushrooms from her as she has exactly 1 kilogram of mushrooms in total. In the third sample, there are no three bags whose total weight is of integral kilograms. So Alice must leave all the five bags and enter the forest with no mushrooms. In the last sample: 1.Giving Sunny, Lunar and Star: (208+308+508)=1024 2.Stolen by Marisa: ((708+1108)-1024)=792
#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <iostream>
#include <limits.h>
using namespace std;
int Max(int a,int b){
return a>b?a:b;
}
int main(){
int num[10],a[10];
int n,i;
while(~scanf("%d",&n)){
int sum = 0;
for(i=0;i<5;i++){
num[i] = i;
}
for(i=0;i<n;i++){
scanf("%d",&a[i]);
sum+=a[i];
}
if(n <= 3){
printf("1024\n");
continue;
}
if(n == 4){
int cot = 0;
do{
int ans = 0;
if(num[0] == 4){
ans = sum-a[num[1]]-a[num[2]];
}
else if(num[1] == 4){
ans = sum-a[num[0]]-a[num[2]];
}
else if(num[2] == 4){
ans = sum-a[num[0]]-a[num[1]];
}
else{
ans+=a[num[0]]+a[num[1]]+a[num[2]];
if(ans%1024 == 0){
ans = 1024;
}
else{
ans = 0;
}
}
while(ans > 1024){
ans-=1024;
}
cot = Max(cot,ans);
}while(next_permutation(num,num+5));
printf("%d\n",cot);
}
if(n == 5){
int cot = 0;
do{
int ans = 0;
int x = 0;
x+=a[num[0]]+a[num[1]]+a[num[2]];
if(x%1024 == 0){
ans = sum-x;
}
//else{
// ans = 0;
//}
while(ans > 1024){
ans-=1024;
}
cot = Max(cot,ans);
}while(next_permutation(num,num+5));
printf("%d\n",cot);
}
}
return 0;
}
#include <stdlib.h>
#include <malloc.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <iostream>
#include <limits.h>
using namespace std;
int Max(int a,int b){
return a>b?a:b;
}
int main(){
int num[10],a[10];
int n,i;
while(~scanf("%d",&n)){
int sum = 0;
for(i=0;i<5;i++){
num[i] = i;
}
for(i=0;i<n;i++){
scanf("%d",&a[i]);
sum+=a[i];
}
if(n <= 3){
printf("1024\n");
continue;
}
if(n == 4){
int cot = 0;
do{
int ans = 0;
if(num[0] == 4){
ans = sum-a[num[1]]-a[num[2]];
}
else if(num[1] == 4){
ans = sum-a[num[0]]-a[num[2]];
}
else if(num[2] == 4){
ans = sum-a[num[0]]-a[num[1]];
}
else{
ans+=a[num[0]]+a[num[1]]+a[num[2]];
if(ans%1024 == 0){
ans = 1024;
}
else{
ans = 0;
}
}
while(ans > 1024){
ans-=1024;
}
cot = Max(cot,ans);
}while(next_permutation(num,num+5));
printf("%d\n",cot);
}
if(n == 5){
int cot = 0;
do{
int ans = 0;
int x = 0;
x+=a[num[0]]+a[num[1]]+a[num[2]];
if(x%1024 == 0){
ans = sum-x;
}
//else{
// ans = 0;
//}
while(ans > 1024){
ans-=1024;
}
cot = Max(cot,ans);
}while(next_permutation(num,num+5));
printf("%d\n",cot);
}
}
return 0;
}
STL 全排列
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。