首页 > 代码库 > 拓扑排序 --- 判断是否有回路

拓扑排序 --- 判断是否有回路

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3823    Accepted Submission(s): 1738


Problem Description
ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many "holy cows" like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost "master", and Lost will have a nice "prentice". By and by, there are many pairs of "master and prentice". But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it‘s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian‘s master and, at the same time, 3xian is HH‘s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not.

Please note that the "master and prentice" relation is transitive. It means that if A is B‘s master ans B is C‘s master, then A is C‘s master.
 

 

Input
The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y‘s master and y is x‘s prentice. The input is terminated by N = 0.
TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,..., N-1). We use their numbers instead of their names.
 

 

Output
For each test case, print in one line the judgement of the messy relationship.
If it is legal, output "YES", otherwise "NO".
 

 

Sample Input
3 2
0 1
1 2
2 2
0 1
1 0
0 0
 
Sample Output
YES
NO

【题目来源】

HDOJ Monthly Contest – 2010.03.06

【题目大意】

ACM-DIY这个QQ群里有很多神牛,也有一些像我这样的渣渣,渣渣们经常在问问题,久而久之,就形成了师徒关系,但是有些师徒关系是不合法的,比如说:A是B的师傅,而B又是A的师傅,总之形成了环就是不合法的,现在给你一些师徒关系,让你判断是否合法。

 

【题目分析】

其实就是给你一个图,让你判断是否会形成回路,如果会就是不合法的,否则合法。

简单的拓扑排序

 

#include<iostream>
#include<cstring>
#define MAX 110
using namespace std;
int n,m,a,b,i,j,k,x;
bool Map[MAX][MAX];
int indegree[MAX];

void topsort()
{
    for(k=1,i=1;i<=n;i++)
    {
        for(j=1;j<=n;j++)
        {
            if(!indegree[j])
            {
                k++;
                indegree[j]--;
                for(x=1;x<=n;x++)
                    if(Map[j][x])
                        indegree[x]--;
                break;
            }
            if(j>n)
                return;
        }
    }
}
int main()
{
    while(cin>>n>>m,n)
    {
        memset(Map,0,sizeof(Map));
        memset(indegree,0,sizeof(indegree));
        for(i=1;i<=m;i++)
        {
            cin>>a>>b;
            a++;
            b++;
            if(!Map[a][b])
            {
                Map[a][b]=1;
                indegree[b]++;
            }
        }
        topsort();
        if(k-1==n)
            cout<<"YES"<<endl;
        else cout<<"NO"<<endl;
    }
    return 0;
}