首页 > 代码库 > Crixalis's Equipment

Crixalis's Equipment

Crixalis‘s Equipment

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 34   Accepted Submission(s) : 14

Font: Times New Roman | Verdana | Georgia

Font Size:  

Problem Description

Crixalis - Sand King used to be a giant scorpion(蝎子) in the deserts of Kalimdor. Though he‘s a guardian of Lich King now, he keeps the living habit of a scorpion like living underground and digging holes.

Someday Crixalis decides to move to another nice place and build a new house for himself (Actually it‘s just a new hole). As he collected a lot of equipment, he needs to dig a hole beside his new house to store them. This hole has a volume of V units, and Crixalis has N equipment, each of them needs Ai units of space. When dragging his equipment into the hole, Crixalis finds that he needs more space to ensure everything is placed well. Actually, the ith equipment needs Bi units of space during the moving. More precisely Crixalis can not move equipment into the hole unless there are Bi units of space left. After it moved in, the volume of the hole will decrease by Ai. Crixalis wonders if he can move all his equipment into the new hole and he turns to you for help.

Input

The first line contains an integer T, indicating the number of test cases. Then follows T cases, each one contains N + 1 lines. The first line contains 2 integers: V, volume of a hole and N, number of equipment respectively. The next N lines contain N pairs of integers: Ai and Bi.
0<T<= 10, 0<V<10000, 0<N<1000, 0 <Ai< V, Ai <= Bi < 1000.

Output

For each case output "Yes" if Crixalis can move all his equipment into the new hole or else output "No".

Sample Input

2

20 3
10 20
3 10
1 7

10 2
1 10
2 11

Sample Output

Yes
No

Source

HDU 2009-10 Programming Contest

//题意是说蝎子需要把n种装备移入洞中,但是每种装备会有Ai的体积,需要Bi的空间才能移,求是否能把全部装备移进去。

//贪心,因为每种装备有Ai的体积需要Bi的空间,并且移进去后会减少Ai的空间,那排序的时候需要根据Ai-Bi,从大到小排序。

#include<iostream>
#include<algorithm>
#include<stdio.h>
using namespace std;
struct stu
{
	int a;
	int b;
}s[1005];
bool cmp(stu x,stu y)
{
	return x.b-x.a>y.b-y.a;
}
int main()
{
	int t,v,n,i;
	while(scanf("%d",&t)!=EOF)
	{
		while(t--)
		{
			scanf("%d %d",&v,&n);
			for(i=0;i<n;i++)
			scanf("%d %d",&s[i].a,&s[i].b);
			sort(s,s+n,cmp);
			for(i=0;i<n;i++)
			{
				if(v>=s[i].b)
					v-=s[i].a;
				else break;
			}
			if(i==n)printf("Yes\n");
			else  printf("No\n");
		}
	}
	return 0;
}