首页 > 代码库 > 1410260946-hd-Wooden Sticks

1410260946-hd-Wooden Sticks

Wooden Sticks

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 1   Accepted Submission(s) : 1

Font: Times New Roman | Verdana |Georgia

Font Size:

Problem Description

There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).

Input

The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.

Output

The output should contain the minimum setup time in minutes, one per line.

Sample Input

3 
5 
4 9 5 2 2 1 3 5 1 4 
3 
2 2 1 1 2 2 
3 
1 3 2 2 3 1

Sample Output

2
1
3

题目大意

        加工一堆木头,长度和重量都不想等,如果长度和重量其中之一变小的话,需要操纵一下机器,每操纵一下机器需要耗时一分钟,刚开始需要操纵一次。求最少时间。

解题思路

       根据题意,需要两次交叉的排序。对于这种问题,可以先对一个进行快排排序,然后在特别考虑第二个条件。

代码

#include<stdio.h>
#include<algorithm>
using namespace std;
struct wood
{
	int l,t;
}woods[5050];
bool cmp(wood a,wood b)
{
	if(a.l!=b.l)
	    return a.l<b.l;
	else
	    return a.t<b.t;
}
int main()
{
	int t,n;
	int i,j,sum;
	int a;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i=0;i<n;i++)
		    scanf("%d%d",&woods[i].l,&woods[i].t);
		sort(woods,woods+n,cmp);//先对一个条件进行排序 
		sum=1;
		a=woods[0].t;
		woods[0].t=0;//比较过后将其标记 
		while(1)
		{
		    for(i=1;i<n;i++)
			    if(a<=woods[i].t)//错误之处 
			    //比较大小的时候特别注意相等的时候该怎么判断 
			    {
				    a=woods[i].t;
			        woods[i].t=0;
			    } 
		    for(i=0,j=0;i<n;i++)
		    {
		        if(woods[i].t!=0)
		        {
					a=woods[i].t;
					break;
				}
				else
				    j++;
			}//根据第二个条件进行比较符合条件即标记 
			if(j==n)//当标记的数量和总数相等时即跳出 
			    break;
			else
			    sum++;
		}
		printf("%d\n",sum);	        
	}
	return 0;
}


 

1410260946-hd-Wooden Sticks