首页 > 代码库 > HDU1051 Wooden Sticks 【贪心】

HDU1051 Wooden Sticks 【贪心】

Wooden Sticks

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 11627    Accepted Submission(s): 4807


Problem Description
There is a pile of n wooden sticks. The length and weight of each stick are known in advance. The sticks are to be processed by a woodworking machine in one by one fashion. It needs some time, called setup time, for the machine to prepare processing a stick. The setup times are associated with cleaning operations and changing tools and shapes in the machine. The setup times of the woodworking machine are given as follows:

(a) The setup time for the first wooden stick is 1 minute.
(b) Right after processing a stick of length l and weight w , the machine will need no setup time for a stick of length l‘ and weight w‘ if l<=l‘ and w<=w‘. Otherwise, it will need 1 minute for setup.

You are to find the minimum setup time to process a given pile of n wooden sticks. For example, if you have five sticks whose pairs of length and weight are (4,9), (5,2), (2,1), (3,5), and (1,4), then the minimum setup time should be 2 minutes since there is a sequence of pairs (1,4), (3,5), (4,9), (2,1), (5,2).
 

Input
The input consists of T test cases. The number of test cases (T) is given in the first line of the input file. Each test case consists of two lines: The first line has an integer n , 1<=n<=5000, that represents the number of wooden sticks in the test case, and the second line contains n 2 positive integers l1, w1, l2, w2, ..., ln, wn, each of magnitude at most 10000 , where li and wi are the length and weight of the i th wooden stick, respectively. The 2n integers are delimited by one or more spaces.
 

Output
The output should contain the minimum setup time in minutes, one per line.
 

Sample Input
3 5 4 9 5 2 2 1 3 5 1 4 3 2 2 1 1 2 2 3 1 3 2 2 3 1
 

Sample Output
2 1 3
很典型的贪心题。

题意:可以简化成给定n个物品,每个物品有两项参数a,b,求这n个物品能组成的序列的最小个数使得每个序列的每两项参数都是非减的。
题解:先按照递增的顺序给物品排序,然后从前往后判断每个物品有多少个能与它组成合法序列,最后输出序列个数即是。这题和南阳上那道矩形嵌套有些像,但矩形嵌套是求最长的序列,不能用贪心,得用DP。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define maxn 5002
using std::sort;

struct Node{
	int l, w;
} arr[maxn];
bool vis[maxn];

bool cmp(Node a, Node b){
	if(a.l == b.l) return a.w < b.w;
	return a.l < b.l;
}

int main()
{
//	freopen("stdin.txt", "r", stdin);
	int t, n, i, j, ans;
	Node tmp;
	scanf("%d", &t);
	while(t--){
		scanf("%d", &n);
		for(i = 0; i < n; ++i)
			scanf("%d%d", &arr[i].l, &arr[i].w);
		sort(arr, arr + n, cmp);
		memset(vis, 0, sizeof(vis));
		for(i = 0, ans = n; i < n; ++i){
			if(vis[i]) continue;
			vis[i] = 1; tmp = arr[i];
			for(j = i + 1; j < n; ++j){
				if(vis[j]) continue;
				if(tmp.l <= arr[j].l && tmp.w <= arr[j].w){
					vis[j] = 1;
					--ans; tmp = arr[j];
				}
			}
		}
		printf("%d\n", ans);
	}
	return 0;
}