首页 > 代码库 > POJ 3624 Charm Bracelet(背包)

POJ 3624 Charm Bracelet(背包)

Charm Bracelet
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 24914 Accepted: 11226

Description

Bessie has gone to the mall‘s jewelry store and spies a charm bracelet. Of course, she‘d like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a ‘desirability‘ factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23

Source

USACO 2007 December Silver


裸的背包


代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int maxn=30000+1000;
int dp[maxn];
int main()
{
    int n,m,w,v;
    while(~scanf("%d%d",&n,&m))
    {
      memset(dp,0,sizeof(dp));
      for(int i=0;i<n;i++)
      {
          scanf("%d%d",&w,&v);
          for(int j=m;j>=w;j--)
          {
              dp[j]=max(dp[j-w]+v,dp[j]);
          }
      }
      int ans=0;
      for(int i=0;i<=m;i++)
      ans=max(ans,dp[i]);
      printf("%d\n",ans);
    }
    return 0;
}



POJ 3624 Charm Bracelet(背包)