首页 > 代码库 > ZOJ3675:Trim the Nails

ZOJ3675:Trim the Nails

Robert is clipping his fingernails. But the nail clipper is old and the edge of the nail clipper is potholed.

The nail clipper‘s edge is N millimeters wide. And we use N characters(‘.‘ or ‘*‘) to represent the potholed nail clipper. ‘.‘ represents 1 bad millimeter edge, and ‘*‘ represents 1 good millimeter edge.(eg. "*****" is a 5 millimeters nail clipper with the whole edge good. "***..." is a 6 millimeters nail clipper with half of its edge good and half of its edge bad.)

Notice Robert can turn over the clipper. Turning over a "**...*"-nail clipper will make a "*...**"-nail clipper.

One-millimeter good edge will cut down Robert‘s one-millimeter fingernail. But bad one will not. It will keep the one-millimeter unclipped.

Robert‘s fingernail is M millimeters wide. How many times at least should Robert cut his fingernail?

Input

There will be multiple test cases(about 15). Please process to the end of input.

First line contains one integer N.(1≤N≤10)

Second line contains N characters only consists of ‘.‘ and ‘*‘.

Third line contains one integer M.(1≤M≤20)

Output

One line for each case containing only one integer which is the least number of cuts. If Robert cannot clipper his fingernail then output -1.

Sample Input

8
****..**
4
6
*..***
7

Sample Output

1
2

Hint

We use ‘-‘ to present the fingernail.
For sample 1:
fingernail:	----
nail clipper:	****..**
Requires one cut.

For sample 2:
fingernail:			-------
nail clipper:			*..***
nail clipper turned over:	 ***..*
Requires two cuts.输出剪指甲的最小步数
#include <stdio.h>
#include <math.h>
#include <string.h>
#include <algorithm>
using namespace std;

int n,m,right,left,minn;
char str[20];
int clp[20];

void dfs(int fig[],int s,int flag,int step)
{
    int i,j,k,tem[50];
    if(step>=minn) return ;
    if(flag)
    {
        for(i = 0; i<=25; i++)
            tem[i] = fig[i];
        for(i = s,j = left; i<=m && j<=n; i++,j++)
        {
            if(!tem[i])
                tem[i] = clp[j];
        }
        for(i = s; i<=m; i++)
        {
            if(!tem[i])
            {
                s = i;
                break;
            }
        }
        if(i == m+1)
        {
            if(step<minn)
            {
                minn = step;
            }
            return ;
        }
        dfs(tem,s,1,step+1);
        dfs(tem,s,0,step+1);
    }
    else
    {
        for(i = 0; i<=25; i++)
            tem[i] = fig[i];
        for(i = s,j = right; i<=m && j>=1; i++,j--)
        {
            if(!tem[i])
                tem[i] = clp[j];
        }
        for(i = s; i<=m; i++)
        {
            if(!tem[i])
            {
                s = i;
                break;
            }
        }
        if(i == m+1)
        {
            if(step<minn)
            {
                minn = step;
            }
            return ;
        }
        dfs(tem,s,0,step+1);
        dfs(tem,s,1,step+1);
    }
}

int main()
{
    int i,j,k,len,fig[50];
    while(~scanf("%d",&n))
    {
        scanf("%s",str);
        memset(clp,0,sizeof(clp));
        for(i = 0; i<n; i++)
        {
            if(str[i] == ‘*‘)
                clp[i+1] = 1;
        }
        left = 0;
        for(i = 1; i<=n; i++)
            if(clp[i])
            {
                left = i;
                break;
            }
        for(i = n; i>=1; i--)
            if(clp[i])
            {
                right = i;
                break;
            }
        scanf("%d",&m);
        if(left==0)
        {
            printf("-1\n");
            continue;
        }
        minn = 999999999;
        memset(fig,0,sizeof(fig));
        dfs(fig,1,1,1);
        dfs(fig,1,0,1);
        printf("%d\n",minn);
    }

    return 0;
}